Direct Control Crash


#1

Just bought and installed the steam version of GSB, and every time I try and use direct control the game crashes the second I give an order. I can see the green line, for instance, of where I’m telling the ship to go but it instantly pops up a “Gratuitous Space Battles” has crashed message. Any help?


#2

G’Day Vazeron1

At this point I do not have much in the way of solutions and only the standard suggestions:

  • Verify the installation since its in steam
  • Head to the debug folder and see if there are any files
  • As a suggestion, remove the debug folders, run the game again, make it crash and then look at the debug folder. That way it is easy to see the latest errors that are related to the crash.

#3

Done all of the above - looking at the debug files the only relevant things I seem to see is the following in errors.txt

Noting else seems to throw any errors at all. Any advice?


#4

I don’t think either of these are it - I get them from time to time but they do not seem to affect the game

I take it the game runs fine if you do not have direct control turned on ?


#5

Generally yes, but retreating in campaign also causes a crash. This has been a somewhat perennial problem for me, whether I bought the game directly from positech or from steam.

My debug.txt file seems to mention it. I removed my online id from the log file but the rest is normal. Retreat test is what I named the campaign, for reference.


#6

After looking at that, the only suggestion I have is a rebuild of the C:\Users\Sara\Documents/My Games/GratuitousSpaceBattles/ Directory.

As a reminder, rename
C:\Users\Sara\Documents/My Games/GratuitousSpaceBattles/
to something like
C:\Users\Sara\Documents/My Games/GratuitousSpaceBattlesold/

Run the game again, and it will rebuild it from scratch, yes you will lose any unlocks and designs, but at this point I want to see if there is something in there that is causing the problem.

If this fixes the solution, we can migrate the required files. If not, then just reverse the process

Sorry I can not be much more help than this.


#7

It’s quite alright! I appreciate the help.

So I rebuilt the directory and something odd happened. The first time I used the retreat command the game ran fine. Direct control still caused a crash but retreat worked. When I went to try again, however, the crash occurred. This is an old old issue I’ve had ever since the campaign came out, retreat and direct commands truly work fine for you?

here’s the debug.txt file again.


#8

Yeah, I have not had an issue with the game.

Here is a random Idea - run the game outside of Steam
You will need to find where steam hides the game and launch the exe from there
(Also might be worth deleting the new C:\Users\Sara\Documents/My Games/GratuitousSpaceBattles/ just to make sure nothing from Steam remains)


#9

Holy crap, I think that actually worked! I’ve been playing GSB for literally years, this is the first time I can use direct orders and retreats! Sweet!

E: And I figured out the problem looks like. Apparently the More Comms mod badly breaks the game. I’ll keep testing to see if any of the other commonly used mods do so as well. My own fault for not doing a real troubleshooting log.

E2: Making my own modifications to the comms.txt file doesn’t seem to effect much. Must be all the new lines.


#10

Excellent. Glad I was able to help you resolve the issue

Yeah, some mods appear to be fine, but as you add mod after mod it gets harder to troubleshoot various errors.


#11

idea as to why that mod breaks the game. i assume that we all just replace the file, but that file doesn’t have the coms for the move orders, which are spit out normally when you issue one