'Do not have content' errors


#1

I’ve recently received a couple of retaliations on a custom map. When I try to play them I get the ‘you do not have the required content’ message. Having PMed the player who sent me the retaliations, I know he’s not using any modded content. I have all the DLC and bought the game via the Positech website.

Any ideas what’s going on? Are there any more details I should provide?


#2

can you post the gsb numbers of the challenges and I’ll investigate.


#3

Thanks Cliffski,

The numbers are 4616423 and 4616099 (I asked the player to send me the retaliation again when it didn’t work first time).


#4

In both cases he has the following stuff installed

base game
order
tribe
swarm
nomads
fedelite (the free add-on)

I bet it’s fedelite :smiley:
viewtopic.php?f=19&t=4755


#5

Ah, nice one, that seems likely.

If I install it, would it be correct to assume it can be unchecked when setting challenges in the same way that other DLC can?


#6

yes definitely


#7

I am also having problems with ‘Do not have content’ errors. I am just now trying to download online content, and haven’t been able to find one that I can download. I have all the expansions, including fedelite now. I want to try out some of the challenges from the Challenge forum (notably the NEC challenge) but I’m not sure what I’m missing. Help is appreciated :slight_smile:


#8

The Best solution is to post a challenge id here of one that gives you errors, and I can analyze it. Failing that, click the option to get the content, and see what webpage it takes you to.


#9

Alright. One challenge I would like to do is 4616638 which is NEC 1. I’ve also tried to “Get Content” but all the page says is:

Thanks for helping! :slight_smile:


#10

That challenge only has the normal base game content required, and I see lots of others have played it too. What version of the game do you have? Have you tried redownloading and re-installing it? That challenge should be playable by anyone.


#11

I have version Full 1.47. I haven’t re-installed because I didn’t want to lose all the stuff I unlocked. I will take a look and see if I can find where that is saved and then reinstall the game.


#12

I am running Windows XP Pro. I made a copy of the “GratuitousSpaceBattles” folder in the “My Games” folder and then uninstalled FedElite, Order, and Swarm using the “add & remove programs”. I didn’t see any others as options to uninstall so I just deleted the game folder. I reinstalled with version Full 1.23 which was what I bought the game at. Then I installed each of the expansions in the order they came out and then installed FedElite last. I re-entered my registration code in the game and when I started it up it updated to Full 1.47. So after the fresh re-install I tried to download the challenge again, I still have the same problem o_O I did not use the folder I copied with my game settings because I wanted to check if it would work with a clean slate game, which it didn’t.


#13

You can’t actually patch from 1.23 to 1,47, you need to re-download the full game, by re-using the BMT download link you were originally emailed, if it doesn’t still work, emauil me and I’ll reactivate it.


#14

Awesome it works! :smiley: Now what files do I copy over into the “GratuitousSpaceBattles” folder so that I can keep my progress?


#15

everything in the \my documents\my games\gratuitous space battles folder should be copyable over, assuming any DLC you used to have is re-installed too.


#16

Sweet its all working :smiley: Many thanks for you help and for such an awesome game! :slight_smile: