Download trouble


#1

I’m having trouble downloading the game.

The page in the email I’ve been sent doesn’t load.

I am product ID 28990005


#2

I didn’t get a web page up either but I got the Save dialog box and it saved OK


#3

I had another go and its still not working.


#4

It’s file link, so generally a web page will not load, but the file save dialog should come up. You may have some security software that prevents you doing this, but if you open your browser and manually enter the details listed in the email, it should trigger fine.


#5

“Failure to connect to web server” is my message no matter what I try. Unable to download the purchased game. Any advice?


#6

I also tried by turning off all security – anti-virus, anti-spyware, etc. Is server down?


#7

It seems fine from where I am, but I’m in the UK, it could be some link between the two of you is down?
You can try emailing support@bmtmicro.com (they are very good) and ask them why you are having problems, I’ll email them myself, but it might help you get a response direct from them. There servers look like they are running fine right now.


#8

Everything working fine now. Server must have been down temporarily. Finished first full game and got stomped in the election. What a gem of a game this is. Funny, innovative and a challenge.


#9

I’ve sent them an initial email which I received a reply to and my subsequent reply is as yet unanswered. They seem to be misunderstanding what I’m saying.

"Hi,

I’ve bought Democracy 2 and I’m trying to download it from your servers.

This is the link I was given:

removed

However the download doesn’t begin and if I try to visit your website by itself then it does not load either.

Thanks in advance for your help.

"

This is the reply I received:

"I have reset your your Product Id and Password. Please Redownload your order from the download page. download.bmtmicro.net/

Please let me know if I can be of further assistance.
Thank you
BMT"

They did send me an email today that said that my CD had been dispatched which is all well and good - not what I paid for however.


#10

Does the new download link they sent you work? If not let me know and I will chase them up right away.


#11

They didn’t really send a new link. They just said that it had been “reset”. It doesn’t work because the problem is in the fact that I can’t load their website in the first place. I have no idea what they can do about it to fix the problem but I’m still unable to download the game 3 days after buying it.


#12

you are unable to get to the bmt micro website? Don’t panic, I will email you a direct link to get the file from my site, rather than theirs, in case someone your isp prevents you getting to their site. but this is strange, as the order page is hosted by them, and must have been reachable?


#13

Thanks.

It is rather odd because I could load the order page. I’ve retried it and the order page works but the download page is still unavailable.

Apparently I can access secure.bmtmicro.com but not bmtmicro.com

Seems pretty odd to me.

I received your email with the download link. Thanks very much!


#14

Got the download page, only it started at 50K/sec–which is horrible–and decreased within 10 minutes to less than 10K/sec–which is impossible. If it continues drifting down, I’ll just have to stop.

EDIT: Phewww. Took about an hour, for a small executable. But at least, it’s here, now.