Endless Battle Crash


#1

Every time I go in to either endless battle, I can choose my fleet, but the moment I try to start the battle, I get an app crash. I’m not sure what else to tell you to help you find the issue. I haven’t seen anybody else complaining about this, so maybe it’s my issue alone. Any guidance on this one?


#2

I’ve got the same problem. The missions and challenges all work fine. Endless battles? Not so much.


#3

Interesting…
The game writes all its errors to a file here:

\program files\gratuitous space battles\debugdata\errors.txt

Is there anything relevant in there? Does the game always 100% crash at that point for you? and excatly what happens just before it crashes?
Cheers,


#4

Strangely, there’s nothing in the errors.txt file whatsoever. Totally blank when I opened it.

For me, the crash occurs during the mission loading splash screen. This in itself is strange, because I almost never seen the mission loading status bar. GSB loads incredibly fast on my system, so I never realized there was a loading bar, actually. :slight_smile:

But when I try to load either of the endless battle missions, the loading bar gets to about 50%, hangs for about 5 seconds, then the game just quits. There’s never been an error window or anything of the sort; it just shuts down. Clearly it’s some aspect of the mission preparation causing the crash (I’m guessing the layout of the AI fleet, but that’s pure speculation on my part).

If there’s anywhere else I could look for logs of these events, please let me know and I’ll try and gather any relevant info.

Also, a side note: it’s great to see the quick turnaround time on your replies to everyone here. Kudos to you for supporting your players so well.

Edited to add: Odd…I just looked at the drawdebug.txt file and saw that it’s listing my old graphics card, an nVidia 8800 GTS rather than my current nVidia GTS 250 card. And debug.txt says my desktop resolution is 1920x1200 rather than the actual 1440x900. GSB is normally running windowed at 1024x768, but the same crash also occurs when running full-screen at 1440x900. Not sure why the desktop rez is wrong, but the card detection might be because I’d installed the GSB demo before buying my current card and before purchasing the full version of GSB. Perhaps the problem is somewhere in here? Going to post the full debug and drawdebug logs in case there’s something useful there.

DEBUG.TXT

DRAWDEBUG.TXT


#5

Just tried to replicate the crash on my laptop (which was playing GSB just fine all day yesterday). Same problem on different hardware; happens with both of the endless battle missions. Even tried playing with just the standard tutorial ships (in case it was one of my user-made ships causing the problem): same result.

Oh well. Guess I’ll just run through the missions and try to rack up some more honor while you work on the issue.

Thanks in advance for the help.


#6

ignore the wrong card stuff, it sounds like your debug files arent getting written (maybe a windows 7 thing?), and its still got the debug ones from my machine…
This crash sounds grim, especially on different machines. Same O/S on both? I’m assuming this isn’t affecting everyone or I’d be hit with severe email attacks on it by now…


#7

I’ve found it. It is indeed a new bug. All my fault. Humble apologies. I’m fixing it now…


#8

Ok, patch 1.26 should fix that. Dang…


#9

cool. two patches in one day. :smiley:


#10

Excellent! Just got back from Thanksgiving dinner at the In-Laws… I’ll patch up the game and give it a go! Thanks!

Nuke…


#11

Whatever you did to fix the problem, it worked. Just ran through Encounter at Andromeda.

Thanks for the quick fix. Fantastic work!


#12

since users with UAC turned on do not have write access to program files unless they explicitly run the program as admin, it silently redirects file writes to “your user folder\App Data\VirtualStore\Program Files”