Error 41 when flipping through ship hulls


#1

I was inside the ship designer, clicking the right arrow button to scroll though ship hulls. The cursor graphic stopped moving, and my normal windows cursor appeared. After about ten seconds, the game crashed out and gave me the following message in a dialog box

“Error 41: Please contact tech support:…\src\GUI_ButtonBase.cpp 110”

After that happened, the game now hangs on the loading splash screen and gives me a dialog box which says

“Error 41: Please contact tech support:…\src\Game.cpp 242”


#2

Almost exactly the same - mostway through creating a cruiser design, I clicked on the engines tab (having already installed a few) and got good ol’ Error 41 (though, like an idiot, I failed to jot down the text that followed).

After trying to restart the game, I was presented with Error 41 again, this time relating to \src\Game.cpp 242

Edit: just checked the error log - the initial error was indeed the same as the above poster, \src\GUI_ButtonBase.cpp 110


#3

does " \src\Game.cpp 242" indicate it is time to re-install?


#4

I have just had the same error in the ship designer (going there fromthe deployment fleet page) It occured when I clicked the second button on the top left (I think that it was defense. I was on the Rabit design. I have also noticed that the ECL laser in “Attack” had a square background and could be fitted in the 2 slots types. I don’t know if it could be linked).

Now I restart the game, it crashes from the first screen (with red clouds) and sends the message given above. I think that I am ready for a reinstall…


#5

sounds like alt-tabbing at any point might be an issue


#6

Aye, guess I’ll be reinstalling too. A pity, as my experience so far has been: going to the options screen to drop the resolution, going to the deployment fleet page, going from there to the design screen, /nearly/ designing a cruiser, and then crashing :slight_smile:

Ahh, betas, how I’ve missed you :smiley:

(And should note, at no point did I alt-tab)


#7

not for me. I was playing with the mouse only.
But I was playing in windowed mode.


#8

I was trying to reinstall after getting that error at the first splash screen but it’s still doing it. Something somewhere has left a trail of nasty that I haven’t found.


#9

Re: alt-tabbing - ah, unless he meant /after/ the initial crash, in which case I had to alt-tab to get to the crash window (plus indeed the fact that the crash window would have tried to gain priority, which could have much the same effect).


#10

And finally (sorry to clutter up the thread) - same here re: reinstalling; no joy, even after manually removing any related registry entries I could find. Hmm.


#11

Hmm, I’m in the middle of removing registry entries.