Error Locking VB


#1

Hello,

I just bought Democracy 2 as I am a huge fan of #1, and was estatic to find out there was a sequel. So I bought it even without trying the demo…

I am running Windows Vista 32bit, with 2.5 GHZ, 2 Gigs of Memory and a NVIDA Graphics card. I can start up the game and get to the country selection screen and the mouse stalls and slowly moves, then I get a Error Locking VB message.

I updated my graphics card, checked for spyware and viruses, and have run the game in Windows XP, 2000, and 98 Compatibility with Administrator Privelages, and nothing seems to be working. Do you know a fix for this? I sure hope so!

Thanks for your time, and creating one of the best games on the market!


#2

Hi, I’m not aware of anyone else with an error like this. Are you overclocking your chip or card? VB errors are often a symptom of that. Do you know what video card you have? The game shouldn’t have frame rate issues on anything but quite old cards (or some bug ridden intel cards).


#3

I just started to get the same D3DEngine error: “Please check publishers website for tech support Details: [Error locking VB]” upon installing the latest Nvidia drivers (195.62) for my GeForce 8800 GTS 512. The error also occurs when I try and start up Kudos 2 (image of K2 window+error). In D2 the error occurs as soon as the main menu background image pops up while in K2 it happens when I mouse over any of the options.

Under the 190-191 drivers, the games would simply refuse to load in Windows 7 x64 (both the RC and retail Pro now) so I guess this is an improvement. Both games worked on the same machine via WINE on Ubuntu 9.04 (with the latest proprietary drivers and what-not) and my machine can run lots of the latest games (in W7) just fine so I doubt it’s the card itself.


#4

I’d like to chime in with this too, I’m having the same issue, with similar hardware. I’m running Win7 x64, with an Nvidia 275GTX card, latest drivers and DirectX. I also tried various compatibility modes to no avail. I tried running it from a Windows XP virtual machine without success (although that’s a whole different can of worms I suspect).


#5

Hi, I’m having exactly the same problem with the game (the D3DEngine error mentioned above) while trying to run the demo version of the game. My OS is Windows 7 x64 as well, with an AMD Athlon II x2 250 CPU and a GeForce GT 240 video card (with the latest 195.62 drivers), and no, I haven’t overclocked any parts of the hardware (yet :P). I haven’t tested it as thoroughly as the previous poster (I wasn’t able to install Ubuntu due to some “fake” RAID-related issues), but I think there’s a remote chance of this problem having to do something with 64-bit Windowses and Vista’s architecture as well. This is quite unfortunate BTW because I really love the game (although when you get elected the 9th time with >80% support or so it gets a bit boring), but I dumped Windows XP for exactly the same fakeRAID problem.


#6

I have this exact same issue, only on Rock Legend (the game loads up and then goes blank with that error).

Win7 x64, with an Nvidia 275GTX card, latest drivers and DirectX.


#7

I am posting because I am also stuck with this issue:

I am running a GeForce 8600 GTS and Windows 7 x64, with the latest driver (195.62). The game runs fine on XP/Radeon Mobile graphics on my laptop. I’ve walked back through the compatibility mode for the program until Windows 98/ME settings to no avail.


#8

This is nvidia making drivers that no longer work with older versions of directx. They are flatly, clearly and obviously not compliant with the way directx is designed to work before Directx8. Frankly, to claim their new drivers are directx compliant is flat out fraud.
It depresses me that driver coders at nvidia would rather add mroe tedious flashy crap to the video driver control panel than bother checking if their new drivers actually comply with the directx specification, but thats video card companies for you.
I bet they do the same thing in a few years with directx9 and even 10 :frowning:


#9

So is it even possible for people using Windows 7 to play the game at all ? Because AFAIK returning to “older” driver isn’t really an option (as they aren’t compatible with Windows Vista/7). Especially for 64 bit OSes. Or is it? :stuck_out_tongue:


#10

I really do not know, to be honest with you, as I don’t have a copy of Windows 7 myself yet, and the game was written pre-windows 7. There may well be some particular video cared driver setting / compatibiltiy mode option that fixes it. It may also be subject to being fixed by a windows 7 patch.
I’m pretty sure I know what the problem is. Democracy and Kudos both mix windows GDI with directx, to get crisp text. That is perfectly allowed under directx, there is ample documentation for it, but it is frowned upon by newer versions of directx. I strongly suspect nvidia just decided ti was too much trouble to support doing it, and there is just no way to tell if a video card supprots the feature or not. In theory, they have to but these various bug reports suggest it’s not the case :frowning:


#11

So then are you able to rewrite that portion of the code?


#12

Not easily, its in about 75% of the code. It would be months of work :frowning:


#13

Wouldn’t be the first time, they did the same thing when they brought out the first generation of DX9 cards I believe.

I’m somewhat glad my University decided to teach me OpenGL instead of DirectX now.


#14

Oh that’s a shame. It’s really not on that they can pick and choose which functions/features to support and still claim compliance. Sounds like they’re deserving of a snotty email to me.


#15

I updated to latest NVidia version that I got a notice from them today, after that Kudos and Democracy 2 both don’t work.

Has anybody already sent a complaint to NVidia?

Would it give more weight to the complaint if Cliffski did it speaking on behalf of a Global games developing conglomerate and all :wink:


#16

I’m looking into if there is a workaround I can do for this now…

BTW I was wrong, this isn’t the GDI issue, its something fundamental about vertex buffers, that seems to have borked dozens of games, judging from a quick google search…


#17

is this on windows 7 64 bit? or vista? 32 bit?


#18

I upgraded my desktop to 32-bit Windows 7, then later did a clean install of 64-bit Windows 7. It didn’t work on either. (I have an NVidia card.) It does seem to work on 32-bit Vista but apparently the on-board graphics on my Vista laptop isn’t powerful enough because after two or three zooms into a policy icon, it gets extremely slow (unless this is a driver problem as well - it’s difficult to properly update my laptop graphics driver).


#19

I have Vista 64 bit Enterprise Edition. Graphic card is NVidia 9800GT in case that matters. Let me know if you need more detailed specifications.


#20

It looks like both windows 7, and 64 bit versions of windows just arent playing well with older versions of directX. Nvidia don’t care at all about older versions, and Microsoft discontinue support for directx and tell you to get stuffed, so it leaves game developers with older engine games adrift to be honest :frowning:
I haven’t heard of anyone with these problems with an ATI or other non-nvidia card, so it is definitely a driver issue. Hopefully there are enough games with similar problems (this seems to be the case) that they will patch their drivers soon :frowning: