Failed to CreateWindow CTD


#1

For some reason, my GSB doesn’t work anymore. Upon starting, it immediately gives an error saying “Failed to CreateWindow. (File could not be created. File already exists*)”. *This part is in Finnish (since my operating system is in Finnish), rough translation by yours truly. Title of the error message is in English, as quoted.


#2

I get this too - the only way to fix is to erase My Documents/My Games folder, but this erases your program as well. I recently bought this off steam, and I dunno what the problem is.


#3

This is absolutely ridiculous, not to mention seemingly unfixable. And what a surprise, the developer of the game has given me a generic ‘lolz it r ure faultz’ response. I’m so glad I got this on sale, AND in a pack, so the cost to me was negligible. Otherwise I would have been even more pissed.


#4

Are you both running this on steam? I can’t see how this could possibly be the game, but could well be steam. Even the simplest program can call CreateWindow(), so it sounds like it’s being corrupted or prevented before then.
And sarcasm will not get you decent tech support, it will just get you banned.


#5

Nope, no Steam. Bought everything from Positech/BMT Micro. However…uh…the game works again. I have no idea what the hell might have happened. I tried it yesterday after running all sorts of maintenance operations on the computer and it still gave the same error. However, today it works fine… weird…


#6

Runnin’ it steam-wise here, and the problem is still here. Weird, it’s definitely -not- steam then. Hrm… Lemme try changing desktop resolution then running it.

Edit: Nope, same problem. It sounds like its refusing to overwrite the folder, and simply CTDing rather than handling the error. Wiieierrdz,.


#7

Are you sure a previously running copy of the game isn’t still running if you check task manager?