Failed to Initialize 3d Engine error ../src/Game.cpp 279


#1

I apologize if this is already been covered, but…
I receive that above error when trying to start the game.
I’m playing on a desktop, so my screen resolution should be plenty large enough I would think.
And I downloaded the game Nov 27, so I should have the current build, right?
Thanks for the help in advance.


#2

I’m getting the same problem! It only started doing this after the 1.26 patch.


#3

I haven’t been able to play GSB since the 1.26 patch because of this crash? no one else getting this problem?


#4

Anyone? If you need more information to help diagnose the problem, please ask. I did pay good money for this game, and would like to have a chance to enjoy it.


#5

Yes;

Got this same message when I downloaded the demo this last weekend. I was hoping to play the demo after I got the same text message but with error code 282 on my steam account. Who do I talk to for a fix?

Sequioa


#6

Actually it just started working for me. Just had to restart my PC. :stuck_out_tongue:


#7

um… ok then… :smiley:


#8

I found my prefs.ini file was blank, so I added the following lines and it worked just fine:

[prefs]
width = 1024
height = 768


#9

Sorry no luck with that.


#10

Ooops!;

Ok, you were right. I am an idiot. Thought it should c:\programfiles\GratuitousSpaceBattles. It should go in C:\Users"name"\Documents\My Games\GratuitousSpaceBattles.

Just reminder I am playing on steam account. Your setup may differ.


#11

stormthirst my savior!! my prefs.ini wasn’t blank but the problem was that the width and height weren’t supported on my other monitor, so when it tried to launch it it failed. Anyways, I just put the proper dimensions for my screen and it works great!

Thanks!


#12

I don’t know how I missed this thread. Does anyone still have problems?


#13

Just wanted to let you know that the default resolution doesn’t work on netbooks, which have a resolution of 1024x576. Or at least my HP Mini does. I managed to edit the pref.ini to fix this, but for a moment there I thought my netbook wasn’t supported because I didn’t have a graphics card!

The game appears to work fine once I changed the settings, but I wonder if some people tried to install GSB on their netbooks, or tried the demo and found it didn’t work out of the box? Perhaps a first-time startup dialog with a screen resolution or windowed option would be useful?


#14

GSB is basically unsupported on anything with a screen height of less than 768. The game is designed for big screens :smiley:


#15

Don’t suppose I could persuade you to add in an option to run windowed in a resolution less than 768 high? It’s really the perfect game for a netbook, not twitchy, no need for leet mouse skillz, and playable in very small chunks.

It’s almost completely playable as it is, only a few screens such as the stats screen and the options screen having a few lines off.

hopes


#16

One day, certainly, I would like to have the game runnable on those laptops, for sure.


#17

I installed the demo (1.25) on my laptop on the road (steam) and ran it happily until I got home and plugged in my external monitor… then I got the “failed to Initialize” error.

Deleting the prefs file made it run properly again.

Dan.

more details:
laptop display resolution: 1440x900
monitor resolution:1280x1024


#18

I still get this problem, ever so often. :frowning: But im not allowed say that anymore.


#19

Hi All,

I want to try out the demo but I’m getting this error. My prefs.ini is:

[prefs]
width = 1920
height = 1080
windowed = 0
sound_channels = 512

I am running on Window XP Home. Pentium 4. Thanks.

Ron


#20

What video card do you have?