Failed to save campaign fleet


#1

After not playing for a while and then investing in the Galactic Conquest expansion, I found I couldn’t complete a campaign - I’ve tried around 10 now I think as various races. At some point I usually get either something like this…
“Failed to save campaign fleet: C:\Users\MyID\Documents/My
Games/GratuitousSpaceBattles/campaignprogress/default/fleets/fleet2.txt
:…\src\SIM_CampaignFleet.cpp 200”
…or just a GSB stopped working with no other message.
Save is then corrupted with the ubiquitous “Failed to find race: /src/sim_race.cpp 130”
I also sometimes get the issue where the game crashes when clicking “Fight” to start combat but think this is logged elsewhere.
While trying to fix I deleted all my game content and my “MyGame/GratuitousSpaceBattles” folder and reinstalled from scratch, shortly after my first skirmish I had another crash but this time it was tutorial_seen.ini that failed to save. Files seem to save normally for a while then I get the crash - I can’t see any permissions or “read only” issues with the save area.
Program is running as admin on W7 64 bit, using steam, with all the DLC up to campaign.
Should also say that even with this problem GSB is still a great game, would be much better if it would stop doing this though :-).


#2

sounds like a general file handling issue. Any malware? nasties can soemtimes hook into windows file access. No chance you are actually very low on free disk space is there?


#3

Thanks for the advice - haven’t seen any issues from my AV on this PC, ran a scan and came up negative, there’s no other suspicious or unusual activity as far as I can see and I have 171GB free on the partition.

I think I have got this to work however - I’m running a Western Digital backup program that came with a NAS and if I disable this - no more crashes - I had a full night conquering alien scum with no issues yesterday and today has been crash free too. Not sure how this could happen but the MyGames area is one of the folders the backup program is scanning.


#4

Well, I have same error and didnt get this to work. Reinstalled several times, deleted all savegames and started over but with this same error after two minutes playing.

Can you please tell me why this isnt fixed already? I can find many people with this error around here with no solution (except “it somehow stopped crashing”).

Im gonna alarm steam, cause 40€ is IMHO too much for unplayable game.