Failing to stay in fullscreen


#1

When I start the game, it seems to load properly, but fails to stay fullscreen. It currently switches between the game and the desktop and eventually stays minimized.

I’m running Archlinux (64bit) with AwesomeWM (A tiling window manager). I have a Ati Radeon HD 4500 series with the proprietary catalyst driver (11.11-1).

Does anyone have a clue what’s going wrong?


#2

Odds are it is AwesomeWM having issues with the SDL fullscreen window and popping the game out of full screen mode. the only times I ever got the game to “pop out” of full screen was when I used synergy and would move my mouse on and off of the linux screen… but the game would eventually pop back into full screen (it may take it 30seconds to a minute). Though I am using the Gnome 3 window manager.(mutter?)

Is there some setting in AwesomeWM that will tell it to NOT mess with the GSB window?


#3

Tested awesome 2.3.3-1… No such problem here… Anything you’re running on top of awesome that might mess with how your windows are laid out? Or maybe something that was changed in awesome from the default? Have you tried starting a blank X session with a terminal and no window manager… Then just started the game from there? If it doesn’t do it under those circumstances, I think it is awesome to blame.


#4

I haven’t had any time to test it yet, but I’m using awesome 3.4.11, so there could be a lot changed since v2.


#5

Why is it?

[size=150]Russel[/size]
[size=85]My billy club weapons is what makes me GREAT![/size]


#6

Why is what?