Fails to initialise 3D engine


#1

I’ve installed the demo, but when I attempt to start the game, I only get a black screen and an error box that reads:

“Error
Failed to initialise 3D engine: …\src\game.cpp 282”

If I acknowledge the error, the game crashes. My video driver is up to date, and I’ve got DirectX 9.0c. Any idea what I can do to fix this? I’d love to get the full game, but I need to know the demo will work, first.


#2

I am experiencing the same issue, and find myself in the same exact situation.


#3

You might want to look in the folder “C:\Program Files\Gratuitous Space Battles\debugdata” (or the equivalent, if you’ve installed into a different location) and see if any of the files located there offer any information about the crashes you are seeing. It might also help cliffski find the cause of the crash if you post some info about your computer’s graphics card and drivers.


#4

OK, debug files…

Graphics and system info.

NVidia GeForce 7900 GS, 256 MB RAM
Driver: nv4_disp.dll
Version 6.14.0011.9107
Date 9/27/2009 16:12:22

Windows XP Professionl (5.1 Build 2600)
AMD Athlon 64 X2 Dual Core Processor 2600+, MMX, 3DNow
2GB RAM
DirectX 9.0c (4.09.0000.0904)


#5

The game is trying to start up in a resolution that doesn’t seem to make sense for your video card. If you delete the whole
\My Documents\My Games\Gratuitous Space battles
folder, then reinstall and run the demo, it should try and match the desktop resolution properly.


#6

Reinstall fixed the problem.

Thank you.


#7

This fixed it for me, too. Thank you.

Sincerely, bravo. This game is awesome. I just purchased the full version and look forward to many hours of entertainment.


#8

I get the same error, although only when trying to run the game via Remote Desktop. :}

Max


#9

I think it’s fair to say that isn’t supported, mainly due to me not being 100% sure what you are doing there…