[Fixed 1.02][Bugs 1.01] Bugs and feedback


#1

Hey,

Been testing the game, so far so good, it’s pretty fun, here’s my feedback.

  1. Alt-tab doesn’t work in fullscreen ( Win10 + Nvidia GTX 1070 ), I get a black screen and then it becomes tricky to quit: can’t get the task manager to show up; need to alt-f4. Alt-tab works in non-fullscreen. Note that the “Fullscreen” GUI option is black or grayed, it is not immediately obvious what this means. Prefer some kind of standardized “check” icon.

  2. Related to 1): when the game crashes and pops up a dialog, it is also invisible, hidden behind the black screen. I can somehow see the error message when I switch task ( dupe component ).

  3. I got a save corruption ( basically the game crashed while saving; I then tried to reload the game, and it froze ).

  4. The very first mission ( “Small Factory”, 25x26 ) starts with $900k. I found the hard way that this does not have room for any mistake ( like bad placement, wrong orientation etc… ). Once you complete a “perfect” line with all the required elements to produce a car, you’re left with around $100k. Then by the time your first car sells, you’re already pretty low. I lost my first 3 games because I wasn’t familiar with the interface and made a couple of beginner mistakes, and that fucks up the game pretty quickly. My point is that I expected the very first mission to be the easiest and the first one a beginner should choose, when it’s not.

  5. Sometimes I do not understand why things work or don’t work. Let’s take this save as an example ( test3. rar ):

test3.rar (28.4 KB)


A. I created a resource importer and attached a conveyor on the bottom-left of my factory. It is linked to other conveyors and stockpiles. I’ve never seen a single resource come out from that importer and I have no idea why. I believe it’s correctly linked. If it is it’s a bug, if it’s not then it isn’t obvious why and that’s also an issue for the player.

B. Sometimes stockpiles never seem to stock anything. In this example I have 4 stockpiles pretty close to each other, 3 of them work but the fourth ( despite having added some items ) never seems to work. Haven’t ever seen a single resource getting stocked in that area, and again I have no idea why.

C. I also often notice that waiting lines at the entrance of some modules are unbalanced. In this example I have 2 fit Engine modules, one of them has 4 cars waiting on it, while the second one is waiting for a car to come in. When a car incoming from the paint modules arrives at the square-cross intersection it seems to prefer going to the first fit-Engine module and does not seem to check if the second fit-Engine module has a lower amount of cars waiting for it or not.

I did notice that when the 2nd fit-Engine module is empty, an incoming car from Paint will always go into it. The problem then is that when there’s no car, the lines are unalanced and a lot of time ( sometimes minutes ) are lost for no good reason.

Overall I think the game is pretty fun but I often feel like I’m fighting against the interface than the game itself, which is a problem. Good luck !


#2

Tried 1.01, still getting a lot of crashes, mostly when I join conveyors together at intersections. I suspect that happens when loops are created.


#3

I’ve made some changes ready for 1.02 which seem to allow all kinds of crazy loops that have been experimented with. Hopefully that will fix the issues you are experiencing.