[Fixed 1.03][Bug 1.02] Fit Steering assembly always waits for car


#1

Hello,

First, I have to say the game works fine, even for an alpha!
I manage to play for a couple hours without crash or major issues (despite being a lame businessman).

However, I tried two things which failed lamentably :frowning:

First: The Fit Steering Assembly is always waiting for cars to arrive. I tried to move it multiple times, to put it in various directions, but still it doesn’t process any car. I think I tried every placement, the car is definitely just before that spot, but still doesn’t process it.
I have attached a save game.
bug fit steering assembly.xml (485 KB)


Second: When I open a sub-menu in the left menu for construction, the icons have a gray “+”. It stays this way, even if I research the item in question.
It happened when I specialized in “Fit engine”: I couldn’t unfold “Fit Steering assembly” even if I researched it. Weirdly enough, the issue disappears if I reload the saved game.
I’m not sure my explanation is very clear though :frowning:
In the screenshot below, it happens with the “Fit steering wheel” item:


Thanks a lot!

Piratmac