[Fixed 1.05][Bug 1.03] Infinite loop in route finding:..\src\SIM_PathFinder.cpp


#1

When I was try to put down a long resource conveyor I was click dragging it and then I tried to move the screen with the cursor keys and the game crashed. I tried several times and it crashed every time. The error in the log is:

30/1/2017 - 23::9 - Infinite loop in route finding:…\src\SIM_PathFinder.cpp 142


#2

I discovered that it happens if you drag the mouse outside the bounds of all the floor space. It does not happen in unrented floor space.


#3

I think this is fixed in 1.04, I certainly cant reproduce it here.


#4

got the same problem here. trying to drag a line for the conveyor out of bounds to the other conveyor lane on the right(screenshot)
i am using V1.03.

http://imgur.com/a/GuJ9T

*Edit:

after reloading the game my business is always crashing, because my conveyor lanes are not working any more.
They are just driving crazy in every direction.

http://imgur.com/a/8xgTh


#5

Hi,
if i build one or Multiple Circles with conveyor, and build a Building near it will crash.

Here are the Screenshots:





Best Regards
Max2605


#6

Hi, I suspect this is due to some general case issues with the resource system which should be fixed in the next patch. Its basically what I’ve been working on (and testing fixes for) since 1.04… :frowning:


#7

Gotta be a real shame Cliff to have everything going so great for 1.01 - 1.03 and then an improvement accidentally crashes everyone’s fun for a few days right when things start taking off. Hope it gets fixed soon, this game deserves all the momentum it can gain.


#8

I’m not 100% sure but suspect that bug was in there all along, unless you know different?


#9

Hi,
I downloaded and Installed 1.05.
Its Din’t crash now if you want it Build over a Circle but if you Build its Crash.


Best Regards and a Nice Sunday
Max2605