[Fixed 1.05][Bug 1.03a] Reproducable crash with save


#1

v1.03a. In my current game, I just rerouted the tail end of my line, diverting around Fit Electronics (now deleted), Quality Control, and Export, routing to a pair of Quality Control/Exports (no Fit Electronics!) at the top of my map. Loading this save on my computer, the game crashes about 7 seconds in; no action necessary. The game freezes up, although the music continues. If I click uselessly, eventually Windows pops up the "ProductionLine.exe has stopped responding.)

The save: drive.google.com/file/d/0B20Q_H … sp=sharing

At one point I tried saving around the same time the crash might have happened; the saving screen opened, the gear progress bar moved a bit, then it froze. The save game looks suspiciously small; I haven’t tried loading it. If it would be useful, let me know and I’ll send it along.

(Also, is there a better way to get saves to your, assuming they’re useful for debugging?)


#2

Thanks for the save, I’ve got it to crash on my PC and am investigating. its some sort of route-related bug, not sure exactly whats causing it yet…


#3

ok…found and fixed it. Some silly assumptions in my code were meaning that if a single conveyor length was over 64 tiles long, the game crashed! I’m coding a way around that limitation now :smiley: