[Fixed 1.05][Bug 1.04] Corrupting save files


#1

When I first started with 1.04 I loaded a save file from 1.03. It worked a few times but then the save file got corrupted. I thought it might just be a conversion problem. So I started a new game, but it happened again. The save file works for a while but then it gets corrupted. So I tried one more time and it happened again. I haven’t noticed what has been causing it but I have attached the latest save game and the debug folder.
Mega.zip (114 KB)
crash_debug.zip (3.38 KB)


#2

I can confirm the crash on 1.04

Faulting application name: ProductionLine.exe, version: 0.0.0.0, time stamp: 0x5891f5e2
Faulting module name: ProductionLine.exe, version: 0.0.0.0, time stamp: 0x5891f5e2
Exception code: 0xc0000005
Fault offset: 0x000aa321
Faulting process ID: 0x1794

Its the same exception and fault offset as found when trying to load my big factory in
viewtopic.php?f=53&t=17780#p82990
the crash occurs at the loading stockpile point.
The relevant error log entry says 3/2/2017 - 15::50 - Assertion failure:filename:…\src\SIM_ResourceStockpile.cpp,linenum:88

(and from a look at the save file structure itself it seems not to be corrupt)


#3

Yup, same problem, I’ll hold on playing due to fear of having my save corrupted.


#4

I’m not sure if it’s related but I also had a save file corrupted today, on a game I had been playing since 1.01. The good news is I was kind of looking for an excuse to start a new factory anyway, but I might wait until 1.05 for that.


#5

Hi,
I also cant load my savegame. Yesterday, installed the Game and I love it. But today when I want to load, the game crashes.
I’m sorry for my bad English.
meins.xml (755 KB)
debug.rar (969 Bytes)


#6

Hey everyone…pretty sure I know what this is. I spent all of yesterday re-writing some code that I think has finally fixed this (and other problems) for good, and am basically spending today doing test playthroughs to ensure it really worked, so expect 1.05 to (with any luck) totally squash this issue.