[Fixed 1.05] [Bug] Crash on Slot Placement

Pretty repeatable crash I’m getting here:

Make a looping conveyor
Now take any slot, and when that slot goes over the loop, crash


I’ll admit I tried it after reading the blog post, but I didn’t see it posted before?

This has happened to me consistently tonight trying to make a looping system but I haven’t tried it before 1.04 so don’t know if this is a new bug or old bug.

Odd that loops can work some of the time but I always get a crash soon after, so I guess for me it may be 100% be a loop error. I guess making a new factory with just a loop would be the only way to know. (and then still not 100%)

Oh it’s 100% repeatable with those steps, and ONLY those steps, for me.

Literally build a conveyor that loops back on itself, and when you click to build a slot, and ghost ANY part of it over the conveyor, blam crash

Now running the loop itself doesn’t seem to present any issues at all, it’s only when I’m rolling new slots over it

FPS is starting to suffer I think, I wonder if he could add an FPS counter debug option?

Just found and fixed this!

  1. Fixed crash bug when preparing to place a new slot over a conveyor belt loop.

it will be in 1.05

Are you saying there are general FPS issues? or just when doing this? This was an infinite loop in code which would mean FPS hell, now fixed, or is it in general?

It seemed like there was maybe a teensy FPS blip when running a larger loop with lots of pathfinding, but not in general, no

Looking forward to having the fix so I can push the limits with a big loop!