[Fixed 1.08][Bug 1.04] Removed importers keep working


#1

Ran into this while trying to get some slots to use parts I was manufacturing:

  1. Hook up Resource Importer and some Resource Conveyors running to a Slot that can use it. Wait a bit for it to be used.
  2. Remove the Resource Importer.
  3. Add a Resource Conveyor into the space just vacated. (This step may be optional.)

Parts continue to be imported from the non-existent Resource Importer.


#2

Same here, latest build on Wine (Linux Mint 18)
The resources keep coming


#3

when you put a ressource importer and delete it after… ressources still getting out of it.
the one just beside the white car on my SS
on 1.06 right now.



#4

as you can see, my production is stopped. no more ressources is comming.
on the first SS you can see ressources everywhere… even out of play. :slight_smile:
i’ll attach the save game if you need it.
To be honest 1.06 is way more stable so far. no crash yet. i got a problem with the valves fabrication. even if i have all the ressources nearby i have a 50% production and 50% wait for ressources all the time.
thanks again for your good work.
savegames.7z (982 KB)





#5

I have a similar problem. I have some importers shutting down so the others have to work overtime. You can see in the screen shot for the line on the right the middle importer is bringing in a trunk and a bumper but, as the pink lines show, they are closer to the importer on the right, which is not bringing anything in. My second line on the left is doing the same thing. The far left importer is not bringing anything in.


#6

I have been playing the game for only a couple of hours and I noticed that suddenly resources were starting to float in mid air around the screen, not just on resource conveyors.



#7

I had the same problem the program crashed and it was gone.


#8

The worst part of this is that none of the resources reach the destination so you’re wasting money while no cars are built!


#9

I keep seeing screenshots of this but cannot reproduce it :frowning:
Yet…


#10

Maybe some good news. I have an old save from 25/01 where this occurred (probably from the earliest release version).

Unfortunately when I load it in 1.06 the ghost resources disappear after a moment and the factory seems to recover (right up until all the money disappears due to importing an entire factory’s worth of materials in one go). However, my recollection is that in the old version the issue persists after loading the save.

Not sure how much you can glean from the save but I’ll attach it if you are interested.
f1.xml (500 KB)


#11

I also have a save from 1.06 where this issue occurs the moment I load the game.

I’ve attached a save file and here is a video of the bug: youtube.com/watch?v=lNqG8S1-s4k
T1.xml (830 KB)


#12

Hi all, I’ve just started playing the game and I’m having this issue as well; upon loading my first save game, the resources float away from the resource importer and then nothing is imported and all of the modules are stuck at “Insufficient Resources”. I also tried an older autosave file and the same thing happens.

I’m on version 1.07. I’m happy to provide any other details that may be useful.



#13

When deleting the Resource Importer, The importer continues to work even after deleting the overhead belt.


#14

Hey @ all,

when deleting a highly used Resouce Importer so the Resource Conveyor is still present and placing a new Resource Importer at the same place it may happen to see a 2nd (or when repeating this a third) queue:

You may find a video related this on youtube:
https://www.youtube.com/watch?v=bMccP6HBqbM

At this point it happens that this doubles the output of the importer so resources will move very close together over the Resource Conveyors.
After saving and loading the savegame the resources hover either straight to the right or or down on the screen:


Someone else who has seen the same?

Kind regards

EDIT (2017-02-13):
Started with the same savegame just a moment ago but no howering rescources anymore. Looks like the last point only happens when leaving to the menu and loading the same savegame again.

2nd EDIT (2017-02-13):
This posting http://positech.co.uk/forums/phpBB3/viewtopic.php?f=57&t=18030 seems to be part of this one.


#15

Thanks, I think I see the problem and have fixed it (with any luck) for 1.08


#16

Hey @ all,

Could this posting be related to mine ‘duplicated resource importer queue’?
http://positech.co.uk/forums/phpBB3/viewtopic.php?f=57&t=18068

I’ve removed a Resource Importer and placed a new one at the same place. After saving and reloading the savegame I got the same floating resources.
Can you remember what you did before this happened?

Kind regards