[Fixed 1.15][Bug 1.14] High Output Powerplant Efficiency crash

Attempting to upgrade a High Output powerplant causes a crash-to-desktop with a 0xc0000005 error.

Can confirm this. The game will also crash when upgrading a regular Power Plant.
In both cases there is no error message but attached the debug files.
errors.txt (88 Bytes)
debug.txt (31.9 KB)
drawdebug.txt (849 Bytes)

Dang. Sorry I missed this. I’ve fixed it in 1.15…

Hi! I just bought this game maybe an hour ago. I am also getting the same game crash, upgrading the regular powerplants. Reloaded game, tried again, same crash.

Ok, i just looked at version, i beleive i have 1.14, and not quite sure how to update the game, will go looking more on how to do this.

I guess I should do alot more reading, before posting anything. Sorry about this. From what i can tell, 1.15 is not out yet? Will be glad to see stuff working, Keep up the great work!

Game version 1.14 is up to date. Version 1.15 is still in progress adding more features and bug fixes like related to this bug.
The game itself checks for a new version one time every day so you will get either an email from humble or a message at game launch that a new version is available.

Just use the email from humble with the download link.