[Fixed 1.15][Bug 1.14] Items in stockpile are half scale / have wrong offset / double up in locations


#1

The below screenshots show some of the items that don’t stockpile correctly. Some seem to have their offset on the stockpile space wrong, others are way too small. Sometimes slots double up. Screenshots below.





#2

I think that happens when you change the requested contents of a stockpile from one component to another. Then it doesn’t clear the removed components and instead the new components get simply placed over the older components that are already there.

At least that’s how I had that happen once.


#3

Interesting. I thought the code was handling that situation ok, but I will revisit it. In fact, I’m not sure I’ve addressed in properly for supply stockpiles, now I think about it…
The actual sizes there are correct. Stuff all has to fit on the same pallet, so the graphics used there are iconic, not literal representations. Otherwise you’d never see the valves or the starter motor :smiley:


#4

I can confirm, have hade situation just a moment ago: I wanted a stockpile cleared from specific items so I hit the red X to remove them from the list. Pending requests for this stockpile resulted in (optically) double in use pallets.

Maybe it would be a good time to look for this suggestion related to stock piles …
http://positech.co.uk/forums/phpBB3/viewtopic.php?f=54&t=18062&p=84041&hilit=stockpile#p84041
… and combine bug fixing with improvement ;o)



#5

I have been unable to reproduce it. I was letting a stockpile order a bunch of stuff, then changing what I wanted before they all showed up, and everything worked as expected, in that stuff that was on the way showed up, and requests were only made to fill up the gaps. I had no double-filling.

Is this happening when the stockpile is already full and then you change the requirements?


#6

on the running process by deleting items on the parts list. My intention was not to waste the money for parts inside so production slot will still request parts from the stock pile even if the are not part of the list but remaining requests to fill up the stockpile as the setting were before will be succeeded.


#7

my factory is bleeding money. cant change price of cars. for some reason its at 138 % ? and cant move goods that are to far from where they are needed have to import :frowning:


#8

Hey stefanr,

with 1.10 some mechanics at pricing changed so it could be possible that the Premium/Discount exceeded its area to the right side.



If the slider is still present just click on it to adjust at 100%. After this it’s possible to readjust at the wanted value between -50% and +100% again.

I hope this will help even it is the wrong topic ;o)


#9

I haven’t changed requirements for the stockpile once full (at least, not intentionally) in any game I’ve played. I often select a couple too many of a particular item then back it back down when I’m choosing what to go in my stockpile, but I don’t recall having done it when I’ve had a full stockpile.

Also, I understand that you can’t have all the components in the correct sizes, but aren’t all the red cranes (? the red things holding up the pieces) supposed to all be the same size? It looks strange that some of those red frames are half the size of others.


#10

So I built a massive production line using stockpiles to test the new resource system and this horrifying thing happened at fit windows:


Frightened me a bit- clearly there is enough stuff there, right? Turns out some of those items don’t count towards the resources in the production slot:


When I switched the import settings, items currently bound for the slot arrived, but the slot refused to consume them. Eventually, it puts new items over top of them, resulting in doubled up items on the pads.

I assume the resources that were inbound are orphaned in some way or just a leftover ghost sprite, because saving and loading deletes them. I think the slots didn’t have enough resources because I set up my servo stockpile wrong, but at least it pointed me to a bug!

(Sorry about screenshot resolution, had to shrink them so I could upload them to the board).


#11

Well seems like you spotted the same thing as JungleJim.

… Merged threads together…


#12

This can happen without changing any settings. It looks like items are used at the same time as other items where put into the stockpile. The simulation in background handles this well bug the grafics output will be wrong.
If you observe such a buggy stockpile (no matter if it’s a Supply Stockpile or production slot stockpile) you will see that one item will always be there while others will put on and picked off the same place over time. So if you ignore that item that will be shown (even the stockpile has no quantity) everything looks fine and the stockpile overview will be correct.

I have seen Supply Stockpiles that were show as completely full of windows and servos but at all not a single item on stock. If you save and load the glitch will be gone for some time.

And: this effect occures more often when running the game on Super Speed.

But at all it does not break the game but can be irritating a lot …


#13

When the stockpile’s inventory criteria is changed, there is a momentary overstacking where items from the previous settings and new settings are stocked:



#14

Looks like the same as mentioned here.

Would you please check if both topics can be merged?


#15

found one reason for such double-in-use glitches at production slots …
If an upgrade like ‘Tire-pressure sensors’ needs to free a slot at a full stockpile e.g. for the Sensor related to this upgrade, the stock amount will be reduced but the graphics will not be updated.

How to reproduce:

  1. Build up a working production line or load a suitable savegame (most detailed production slots & upgrades unlocked)
  2. remove a ‘Fit Tire’ slot and ensure no vehicle can roll in when placing a new one at the same place

  3. place a new ‘Fit Tire’ slot at the previous place but don’t buy the ‘Tire-pressure sensor’ upgrade
  4. wait till the slot has been fully supplied with tires

  5. buy the ‘Tire-pressure sensor’ upgrade
  6. wait till the necessary Sensor has been supplied (should be placed without removing the tire at the stockpile gfx)

  7. connect the line and the ‘Fit Tires’ slot so production can go on

  8. watch the single Sensor at stockpile - when consumed the tire previously removed from stock should remain


#16

I found a myriad of issues with the code for this yesterday and finally (I think!) fixed it. I also fixed a load of stuff along similar lines for supply stockpiles. Its all working way better in the next build!


#17

Sounds good, can’t wait for the next patch :smiley: