[Fixed 1.16][Bug 1.13] Slot loops; never finishes / Removing Importers Loops Game State


#1

TLDR: Hi, I made a recording of a bug that appeared after adding the 4th robot. I downloaded the game tonight, so that would make it version 1.07 I presume? youtu.be/P87_QaXltXc

First off: Cliff you seem like a wonderful and energetic individual. I love games like this one and look forward to see it progress. Making this on your own must be a daunting challenge but you seem more than up to it.

Kind regards,
F


#2

Hmmm… I have seen this once but not been able to recreate it since. Did you apply the upgrade whilst the car was already being worked on? The minute I can reproduce it I can get close to fixing it :smiley:
Anybody else encountered this?


#3

In this save game (created in 1.9, but bug still confirmed to be present in 1.10), there is a Fit Hood slot that loops on the same car. The progress bar keeps filling then emptying and the car never moves onward. It persists after quitting and reloading, and even after upgrading to 1.10. The Fit Hood slot in question is roughly northwest from the start location. There is a single power generator placed next to it to hopefully make it easier to find.
Copy of the save game: drive.google.com/file/d/0B20Q_H … sp=sharing


#4

The supply pile for the Fit Hood in question isn’t actually connected to any inputs. Making that connection fixes the problem. However, as there are several hoods sitting in the Fit Hood supply pile, it doesn’t seem like this should be blocking progress, let alone causing the weird looping behavior.


#5

Ah yeah I see the looping fit hood thingy…

I think whatever is causing the bug is also related to another that thread as well where someone posted a video showing the same weird looping behavior in a Fit Accessories slot.

… merged threads together …


#6

Check this out:

So…I was trying to figure out why my manufacturing wasn’t working. Even though all the stockpiles were full it would only say no export room, so I removed all my importers to try and troubleshoot it and nothing seems to work- it just loops forever acting likes its trying to do something, but it never does. Also, the expenses still slowly tick down so this would eventually bankrupt you.

To clarify:
I have all the resources necessary to complete this car in my manufacturing stockpiles which are connected via resource conveyor and I also have a conveyor for the cars to be exported. SO there should be no reason this shouldn’t work. Instead for some reason the game simply stops working when you don’t have importers.


#7

I have seen this before but can’t find the post anymore. As soon as the slot is connected to a resource importer it should work again.
This happens on slots with more than one task and will result either in repeating the same task forever or - as mentioned - loop through the whole procedure.


#8

thats my point though, it shouldn’t need a resource importer when I already have resources in stockpiles that the game simply refuses to use!


#9

I have 3 Make Axle areas feeding into my Fit Front Axle and Fit Rear Axle slots.

I wanted to restart my line so I could incorporate upgrades into my next car model so I deleted 1 Resource Conveyor from the Resource Importer and expected the Make Axle areas would use up the last of the Steel on their resource pads and then stop. Instead, the Make Axle areas immediately stopped making axles even though the resources were still available.


#10

Hey,

never seen this at a single-task-slot but could be related to this ‘[Open][Bug 1.10] Removing Importers Loops Game State’ topic.

Kind regards


#11

Possibly to some extent, however it doesn’t appear to loop, it just stops producing the axles all together until I reconnect the Importer.


#12

… found the other post while looking for another one:
[Open][Bug 1.10] Slot loops; never finishes


#13

looks like the same behavior, but I got it through simply deleting an importer, not adding an upgrade. related? maybe.


#14

Have you seen the messages that is shown for just a very short moment in the video?
The message is ‘No route for resources’:

So removing a Resource Importer or removing the only one Resource Conveyor between a slot and a Resource Importer have the same result: No way to request components from outside the factory.


#15

I think GenBOOM’s encountered loop bug is the same as the one from Badwulf

Even Cliff wrote that he has seen it happen but hasn’t been able to reproduce it.

… merged Threads together …


#16

It is easy to reproduce:

  1. take a running factory with slots that have to process several tasks (like Chassis Assemble)
  2. cut the Resource Conveyors or Resource Importers that feeds this slot but DO NOT remove the Resource over the slots stockpile
  3. watch the slot

Attached a savegame to do this easily:
Cut the 3 connections to the Chassis Assemble …




… and the Chassis Assemble will run into this loop.
pre1.11.xml (366 KB)


#17

thanks for figuring it out, didn’t feel like trying to reproduce it…


#18

… tested the behavior of a single-task-slot again. It takes some more time before the slot loops the task without finishing it but as soon as it is connected to a Resource Importer again it will work as before.

Used the same savegame, removed the Resource Conveyors around the slot …


… and the next car that enters the slot effects the loop:


So from my side both topics can be merged.

[Edit]
The other topic has been merged with other threads so here is the actual link.
[/Edit]


#19

Thanks for this, I’ve noticed it a few times, but haven’t found the time to track down the exact cause. I will try to look at this before the next patch as I believe it to be one of the more commonplace and annoying bugs…


#20

Hi,

I have noticed fit rear bumper job in the Fit Body Frame Stn is constantly repeating itself and not progressing.
Thanks.
Bodyframe bug.zip (640 KB)