[Fixed 1.22][Bug 1.21] Components freezing/not shipping unless production facility highlighted


#1

I think this is a bug?

I get strange block ups with Servo’s and Brakes where:

  • The slots are waiting for the component
  • The production facility or stockpile has plenty
  • The components don’t start to move until I select the production facility with the mouse.

Here’s a video showing this happening for Servo’s, but I’ve also seen it happening with Brakes and Tyres.

youtu.be/-P2DtyNeFpA


#2

Hrm, I kept playing for a while in this save game and am now even more broken:

youtube.com/watch?v=3FQ96oO … e=youtu.be

Seems like it’s at a stalemate. I can’t proceed?


#3

Errors file and savegame attached.
largey mc huge face.zip (203 KB)
errors.txt (7.58 KB)


#4

Hi, I’ve tried your save game, and it seems to run fine with servos being imported from a nearby facility making them, or the nearest import bay, regardless of whether I highlight the slot or not. HOWEVER I am testing this on 1.22 which has had some routing bug fixes so… Maybe I’ve fixed it? I’m patching the game Friday so with luck that fixes it.

I’m interested to hear about it being related to highlighting the facility though… Theoretically doing this makes the facility check its status more often, but it should still check its status every 0.6seconds any way. Have you seen a persistent stall in progress that’s immediately fixed simply by clicking on the facility?


#5

EDIT: OMG Think I’ve just found and fixed this! Expect it fixed next patch :smiley:


#6

I’ve had exactly this issue with window production - thrilled to hear you’ve found the bug in question, it was really driving me spare!


#7

Thanks cliffski,

Confirmed with 1.22, the line is back in action!