[FIXED] floaty tooltip text and crash on cure screen

On the cure screen I was hovering over the ‘man with pill next to his head’ icon for Soothes Cough cure and received text showing me that the new sufferers was (down?) 443%. This text also duplicated itself further up in a text string all by itself. At this point the game froze up and started getting laggy. It seemed like it was going to be okay and sort itself out, but the text remained on screen as I moved my cursor (it was attached to my cursor along with the tooltip), and the framerate was dropping. I feel like there was a memory leak or something. Shortly after the game crashed. Only info I can provide is that at the time I had two basic drugs out, which both had the soothes cough cure attached (one also had the eases asthma cure).

Here’s a screenshot:

Anyway, I’ve been having a lot of fun with the game so far, no other issues :slight_smile:

Hmmm very interesting. The first crash! (That we are aware of). We shall investigate…

I had a very similar thing happening just without the crash, it looked like some memory leak after getting into the cures tab and hovering over the tooltip informing which company sells which amount of the drug for the given illness. After trying to get back to production the game started to lag and also additionally twice it seems not to response anyhow. It got back to some fine work but the tooltip window from the cure tab stayed there in all the other tabs. It also fended off after I think going back into the cure tab, clicking on an another drug checking whic company sells how much and than going back to the normal production tab.

I got a screen shot of the information tooltip floating in the production tab.


Also since my first post: AWESOME JOB!!

How weird. Pantalaimon, you don’t happen to have a save of this setup do you? If so I might be able to reproduce it at my end. It’s always so hard to fix this type of bug when you can’t reproduce it. If so, you can send it to me at support@twicecircled.com

If not, that’s OK. I will definitely look into it.


I will surely send you my save data because this problem did actually occur yesterday several times but it always happend after about 40 min into the game.


Unfortunately I hadn’t saved the game before that point (it was only about 30 minutes in to the game), so I don’t have any save data, unless the game saves anything automatically that might help you?


I’ve got a save file with this problem. Just load the game go to the Cures Screen and click on “Antibiotic” and hover over the supplied circle the pop up appears and looks broken showing 443% and other strange text on other parts of the screen. Not long after the screen locks up and a few seconds later the game crashes.

Hope that helps.

(file is zipped .sav files not allowed).
L2M1.zip (14.8 KB)

Hi there, I used your save and tried to follow your instructions but I could not reproduce this at my end. It could be that I fixed it inadvertently or perhaps it’s got a very specific trigger. Let me know if you continue to run into it after v0.41.00.

Just tried it with the latest update and the problem has gone away!