Fixing The Sound Bug (slowdown 1.03)


#1

To anyone who has the possible sound-related slowdown in version 1.03…
Does the frame rate also drop when you slow the game down? You can see using Fraps (fraps.com).
I have a feeling that it is related to the sound pitch shifting. I am investigating now…


#2

Yes 1 frame per second is the reading in the upper left hand corner.

It starts the moment you speed up past 1.0.


#3

On an XP Pro 32 laptop I do not get the slowdown when I set speed below 1, only when I set it above 1.

Just in case you missed it on another thread - my gaming PC has a XP Pro 32 and Win7 64 dual boot and I only get the problem on XP Pro 32 on that machine.


#4

I didn’t want to post this on YouTube so I put it on my site.
Here is a video of it happening recorded at 30 FPS

ultimatebattles.com/ProofOfConcept.avi


#5

I did the FRAPS test @ 1440x900
Speed 0.2-1.0: Fairly steady at 60ish FPS
@1.2 (and up): Drops quickly to around 10-30 FPS

At resolution 1280x800: FPS is pretty steady at 60FPS

Okay…here’s an interesting result. In the previous results, my desktop resolution was 1280x800. Surprisingly, if I set my desktop resolution to 1440x900 before testing @ 1440x900 in GSB, I get FPS pretty close to 60ish, sometimes dropping a little to the 50s, but none of the jerkiness from before…

I have no idea why having resolution > desktop would have this effect on framerate at accelerated speed for me, but there you have it…


#6

1.04 fixes it with the new sound speed toggle.

you rock


#7

w00t. I had hoped it might, but its great to hear that is the case. Looks like some sound hardware sucks massively at speeding up and slowing down sounds.


#8

Confirmed it works for me as well. What also works is disabling the sound acceleration in Windows (which is what my unaffected Win 7 installation currently has setup, I think).

I’m using onboard “Realtek HD Audio Output”, which looks to be pretty common (Valve HW survey). Assuming you can’t detect the sound device type, might it be worth defaulting that option to Off?


#9

Confirmed that the disable pitch shifting fixes things for me as well (in the cases where I had slowdown). I also have Realtek Audio HD.


#10

Strange thing:
The slowdown got fixed with the patch (1.04), but disabling pitch shifting was not necessary (in fact it seems to work just fine now, the battle sounds…amusing at 4x).
Also running onboard realtek HD.
The only problem remaining is that the effect volume is still ridiculously low when not zoomed in all the way.