Galactic Conquest in steam on a mac


#1

I encountered a few problems but have managed to fix all of them so far. Maybe this will help others with similar problems. I’m running through Steam on a Mac and have all the DLC packs installed.

I encountered the bug that said I already had the Galactic Conquest DLC. Tried to launch and did not work. Bought the DLC installed and worked fine :slight_smile:

I was playing the campaign for a couple of hours, starting and deleting a number of campaigns after being completely destroyed as I figured out how it all worked. At some point the black back ground of the star map turned white for both the full star map and individual system screens. The deploy and battle still had the black back ground. Other than the color change everything seemed to work. But boy is it hard on the eyes with a bright white screen.

I fired it up this morning and it installed a updated version then crashed with a could not find a particular directory folder function (campaign) Sorry, but I forget the exact message. This crash happened every time the program was launched.

The fix for both problems was to right click the game in the steam library, select Properties, go to the local files tab and click the button marked: “Verify integrity of game cache…” It found 16 problem files, downloaded and replaced them and everything seems to work fine.

Great game by the way.


#2

Follow up:

Another version downloaded this afternoon when firing up GSB. Encountered the white screen again in the campaign map/system screens. Did the above verify of steam cache, it found two bad files, replaced them and so far so good…