Game Crashes when Using Order Acolyte Fighters


#1

Very odd bug. I just installed the Order expansion pack and everything works fine - as long as I don’t deploy any fighters. The battle will proceed normally until about 3 seconds after my fighters open fire (weapon doesn’t appear to matter, have tried lasers and rockets so far). Then it will hang for a few seconds and crash. Didn’t see anything obvious in the debug files.


#2

That is a weird one
Any Mods installed ?


#3

No mods installed, just the Order expansion pack. I’ve tried re-installing the expansion pack, as well as deleting and re-designing my fighters. No luck. The bug also applies to enemy fighters, but once again only the Order seems to be affected. I can still fly Rebel fighters, etc. just fine. After poking around a bit, I’ve found that the crash usually occurs right about when the Acolytes reach the cruisers and frigates. I have also tried other types of Order fighters - same problem. It’s not just the Acolytes.


#4

Thats a new one on me. What video card do you have? Have you tried disabling all the efefcts under options are re-trying? or tried fighting a mission with just a single acolyte fighter and nothing else (likely a short fight ). Just wondering if its a video card or CPU/ memory related crash.


#5

I just tried uninstalling, then re-installing the whole program. No dice. Same crash error. I’m going to try re-downloading the expansion pack, I’ll let you know how that goes.


#6

Now this is interesting. I can get everything to work fine if I turn off the “Debris” graphics option. I don’t know why that would be a problem - it worked just fine before I tried playing the Order (and still works fine, as long as no Order fighters are present). I’m going to keep playing around for a bit to see if I can get it to work with Debris on, since I just love seeing Cruisers get chewed to pieces by enthusiastic fighter pilots.

My video card is an NVidia GForce GTX 260M, and previous ran the game just fine at full resolution with all settings enabled. I don’t know what it is, but something about the Order fighters and Debris is crashing the game. Here are my debug files:

----DEBUG FILE----
Windows 7 detected
GSB Debug File. App version Full 1.36
Desktop resolution is 1680 x 1050
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine

Initialising 3D Engine
Driver : nvd3dum.dll
Description : NVIDIA GeForce GTX 260M
DeviceName : \.\DISPLAY1
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
About to Create 3D Device with width: 1680 and height : 1050
Attempting hardware Vertex Processing
Finished initialising 3D Engine
Initialising Render target of 512 X 512 rt_ship
rt_ship
Initialising Render target of 2048 X 2048 rt_offscreen1
rt_offscreen1
Initialising Render target of 2048 X 2048 rt_offscreen2
rt_offscreen2
Initialising Render target of 2048 X 2048 rt_transition
rt_transition
titlescreen2048.bmp
cwfont20.dds
zekton16.dds
box_background.jpg
textbutton.dds
textbutton_h.dds
dialog_titlebar.dds
menu_backdrop.jpg
gui_dragbutton.dds
gui_scrollup.dds
gui_scrollup_h.dds
gui_scrolldown.dds
gui_scrolldown_h.dds
border_depth.dds
debris.dds
contrails.dds
escapepod.dds
escapepodengines.dds
shield_impact.dds
client_interlace.dds
dialog_client.dds
19px_highlight.dds
19px_highlight_black.dds
smokeclouds.dds
runninglight.dds
shield_collapse.dds
checkbox.dds
checkbox_checked.dds
scenario_skirmish.dds
scenario_survival.dds
bg1_icon.jpg
achieve_empty.dds
achieve_bronze.dds
achieve_silver.dds
achieve_gold.dds
tooltip.dds
filterbuttons.dds
square_box.dds
square_box_h.dds
square_box_brown.dds
Order_Trinity_Cruiser.dds
Order_Crusader_Cruiser.dds
Order_Temple_Cruiser.dds
Order_Acolyte_Fighter.dds
Order_Saviour_Frigate.dds
changeracebutton.dds
newshipbutton.dds
bg1.jpg
strip_fill.jpg
strip_fill_red.jpg
module_locked.dds
Alliance Alligator Cruiser.dds
Alliance Cobra Frigate.dds
Alliance Hornet Fighter.dds
Alliance Python Cruiser.dds
Alliance Scorpion Fighter.dds
Alliance Shark Cruiser.dds
Alliance Swordfish Frigate.dds
Alliance Wasp Frigate.dds
order_turret_gun1.dds
module_powergen_v1.dds
module_engine_2.dds
gui_sliderbar.dds
deployment_range.dds
fillbar.dds
progress_bar.jpg
loadscreen_python.bmp
star.dds
Order_Acolyte_Fighter_sprite.dds
order_hulks.dds
turret_blast_red.dds
turrets_order.dds
shield_blast.dds
shield_scroll.dds
shield_blast2.dds
order_shield.dds
armourglow.dds
radiation.dds
Order_Crusader_Cruiser_damaged.dds
particles.dds
order_engineglow.dds
engine_colors.dds
structural_tractor_beam_alpha.dds
structural_tractor_beam_color.dds
Order_Crusader_Cruiser_order_glow.dds
Order_Crusader_Cruiser_hulk.dds
breakup_alpha.dds
beam_blue_atlas.dds
turrets_federation.dds
Order_Saviour_Frigate_damaged.dds
Order_Saviour_Frigate_order_glow.dds
Order_Saviour_Frigate_hulk.dds
beam_green_atlas.dds
turrets_alliance.dds
lightning.dds
repairbots.dds
alliance_shield.dds
Alliance Alligator Cruiser_damaged.dds
allianceengineglow.dds
Alliance Alligator Cruiser_hulk.dds
plasma.dds
Alliance Cobra Frigate_damaged.dds
Alliance Cobra Frigate_hulk.dds
Alliance Hornet Fighter_sprite.dds
alliance_hulks.dds
beam_orange_atlas.dds
Alliance Python Cruiser_damaged.dds
Alliance Python Cruiser_hulk.dds
Alliance Scorpion Fighter_sprite.dds
Alliance Shark Cruiser_damaged.dds
Alliance Shark Cruiser_hulk.dds
turret_blast_purple.dds
Alliance Swordfish Frigate_damaged.dds
Alliance Swordfish Frigate_hulk.dds
turret_blast_yellow.dds
Alliance Wasp Frigate_damaged.dds
Alliance Wasp Frigate_hulk.dds
minimap.dds
battle_buttons.dds
fleet_overlay_icon.dds
green_score.dds
red_score.dds
asteroids.dds
missile_flare.dds
missile.dds
bullets.dds
target_overlay_line.dds
range_marker.dds


#7

The debris can be pretty intensive on video cards, especially if large squads of fighters blast away at hull very rapidly. The amount of debris is capped, and shouldnt cause a crash under any circumstances, but it sounds like your video card is struggling with it for some reason :frowning:


#8

I doubt this is a video card issue. The game did just fine with debris before I picked up the expansion pack. It’s only after I added the Order that it had problems. Technically, it still runs fine with debris on as long as I don’t fight as or against the Order. Also, it crashes during the first portion of the battle, before any debris has had a chance to actually show up. Personally, I’m wondering if there is a corrupted file somewhere that is only accessed when Order fighters either start attacking or start taking hits. I’ve tried re-downloading the expansion pack installer, but no luck there. I’m going to try the other download mirrors next and see if maybe that fixes it.