Game doesn't launch (Steam)

Just bought the game on Steam, it doesn’t start. Any combination of DLCs on or off, compatibility modes, administrator access, etc. Tried reinstalling DirectX. Tried lowering my screen’s resolution. Nothing works.

At first after pressing ‘Launch’ it would do something(?) and Steam would tell me it was running, but nothing would happen. Task Manager would say that Democracy 3 (32bit) was running though.

Now after reinstalling not even that happens. It tries to launch like before but then nothing happens. It doesn’t appear in Task Manager anymore.

I have no idea where the debug logs are stored, so I can’t read them to try and figure it out anymore.

New Computer. Running Windows 10 with an i5, PCmate B150 mobo, 8 gigs or ram and will be adding another 8gb soon. Does my graphics card even matter?

Democracy 3 Africa won’t start either. Is it having the same issue?

Edit: I somehow have a steam trading card now…

1 Like

So coming back after a few months, I’ve found the debug folder. It is empty. Even after trying to start the game (with the same issues), there is no debug file in the debug folder.

Game doesn’t work for almost anyone anymore on windows 10.

I was able to get a refund from Steam, as its apparently a broken game.