Game fails to initialise (not graphics prob)


#1

Hi

I installed the demo and it worked first time, really enjoyed it! When I went to close it down it crashed and I had to reboot. From then on whenever I try to start the game I get the following error:

“The application failed to initialise properly (0xc0000005).”

I tried uninstalling the game and deleting the GSB folder in my docs folder and then re-installing but still same error.

Looking at the debug files one of them say’s Vista is detected but I am running XP. Also my desktop resolution is actualy 1680 x 1050. Bellow are the debug files:

[i]----DEBUG FILE----
Windows Vista detected
GSB Debug File. App version Demo 1.23
Desktop resolution is 1920 x 1200
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine
releasing D3D engine
D3D released
END DEBUG—

24/10/2009 - 17::31 - Ship Hull not found ->Imperial Legion Cruiser hull:…\src\SIM_ShipHull.cpp 488
24/10/2009 - 17::31 - Ship Hull not found ->Imperial Legion Cruiser hull:…\src\SIM_ShipHull.cpp 488
24/10/2009 - 17::33 - Ship Hull not found ->Imperial Legion Cruiser hull:…\src\SIM_ShipHull.cpp 488[/i]

Any sugestions?

Thanks


#2

Those debug errors look like they are in fact either from an earlier install, or came with the demo itself (in other words they are not from your machine).
This sounds like something fundamental. Does it get to draw a window, or take over the monitor, or does it crash with a windows error before doing anything?
Has anything changed on your machine since the time it ran?


#3

Hi

Thanks for getting back to me.

Nothing changed that I can think of. After I played it for the first time it crashed when exiting and I had to reboot. After that it has never worked. When I uninstalled it the first time I deleted the folder in my docs and since I’ve re-installed the game and tried to run it the folder has never came back.

Nothing happens when I try to run the game now apart from the error box. No flickering of the screen or anything, just the error dialog box straight away.

Thanks


#4

Thats very weird. The thing about software is it doesn’t tend to modify itself, and I know for a fact GSB does not. If it worked once, it should always 100% work the same way exactly, unless something has changed on windows.
It could be a driver issue, a windows update problem (that may have installed silently if you have windows update turned on) or could be a hardware problem, or a virus or spyware problem…
I can suggest restoring windows to the date before GSB was installed (it should have automatically created a restore point then) and doing a major check for disk errors and viruses. I wouldn’t be surprised if that fixed it.


#5

Yes I agree, it is very strange.

The thing that gets me is that after reinstalling the game it still doesn’t work.

I dont have auto update activated, I ran a spyware/malware scan a couple of days ago and nothing showed up. The only thing I can think is that its something to do with my registry when I rebooted after the first time I ran the game. Can’t restore as I always de-avtivate it.

I can definatley say this is the first time I have had a problem like this with a game, ie it works fine once and never works again, doesn’t even ever look like it might work!

Saying that I dont think it’s a problem with the game as I’v had a search and cant find anybody mentioning a similar problem.

Well I can’t figure it out, just have to live without it I suppose.

Thanks

Barry


#6

Does vista have “my documents” folder? Did you delete my documents/my games/gratuitousspacebattles folder too when you uninstalled the game?