Game updated to version 1.13


#21

Yes that fella contacted me too, I told him to go buy it lol

Posting was only an issue when I tried to copy/paste the error message from the debug file, said ‘unable to carry out command’ or something technical tomfoolery like that :wink:


#22

Weird. I can’t actually post the line. Pressing preview…

… I can see my message fine. When I add :

No_free_channels:…\GUI_Sounds.cpp_383 and press preview…

I get a 406 error… unless I add those underscores instead of spaces. Its too cold and too late here right now to figure this out but that’s what was in my debug file, repeated about 20 or 30 times after I started a new game.


#23

This game has been installed since Tuesday 6-26 at 10:42am (it’s now 4:17pm Thursday 6-28 ) and have used it frequently since then. The debug.txt file is 377,604 bytes and lines are:

13 lines with "WARNING_-_No_random_translation_keys_found" 40 lines with "DrawText_failed:" 643 lines with "Rebuilding_lost_textured_sprite_pointer" 8319 lines with "No_free_channels:_..\GUI_Sounds.cpp_383"

I don’t understand, I’ve been trying to post this for 11 hours and got the 406 but after reading UNIVAC’s post I added some underscores and it went through. HUH! :open_mouth:


#24

actually the first 3 of those errors aren’t errors, just information for me :smiley: The last one is an error, I think I’ve fixed it, I’m waiting to hear back.


#25

glad it makes sense to you :smiley:

yes, sixteen instances of (‘button mousing’ = ‘end of sound’)


#26

Also cliff, is every rehearsal spot s’posta have ‘rehearsal_bg.jpg’ as the background now? On the last version were they not all different according to the quality?


#27

No, rehearsals have always had the same backdrops as I recall :smiley:.


#28

Okay. I thought I remembered differences.

Upon trying to check (I still have the old version installed; renamed the ‘My Documents’ folder back to the other one - ([size=75]cd f:\midox, ren kudosrocklegend kudosrocklegend11, ren kudosrocklegend1 kudosrocklegend[/size]) but ended by screwing up both installs [size=84]{ERROR - Failed to init FMOD:…\GUI_Sounds.cpp_71 (The operation completed successfully.) [OK]}[/size]

I still have the 1.1 setup but [size=67](albeit inadvertently)[/size]overwrote the older setup file so …

Re: The posting of pasted error messages; evidently, the only space that needs to be changed is the one between the “cpp” and the number (cpp_71 in the above example)


#29

debug.txt only shows the ‘information for you’ now, no errors. My sound is fixed.

Have you ever figured out the ‘speechless bug’?
Somewhere here I put a picture, don’t remember where but here’s a fresh one:

It’d be helpful to know what these guys are saying.


#30

OK sounds seem to be working now, however, when I do my first gig the game crashed and I get an error that says:

Failed to mute music:…\GUI_Sounds.cpp_135 (The system cannot find the file specified.)


#31

cliff ever since i dnloaded n installed vers 1.1 i keep having crashes when im in the mini game practising… can you check what is wrong in the code there please n see if u can fix it the game is unplayable for me as it keeps crashing now.


#32

I’ve been playing the game since it was released. I had no idea the mini-game even had sound, though I did find it odd that it didn’t. I am using a Soundblaster Live 24-bit. I installed the new drivers that were made available 6/25. I’m not sure what the fix is to get the sound to work, but I thought I would add to the people with SB’s who have no sound. I’m really enjoying the game anyway. I just wish that one dude wouldn’t quite before the big gigs leaving me in the red for the last few months of time lol.

I own Kudos too so when I tried the demo, I only lasted a few minutes before I had to buy it. You make fun, simple, “I can drink a beer and play this game” games. Thanks for the hours of enjoyment Cliff. I’m an old school gamer too. 43 years old!! Finally living my Rock Star dreams lol.


#33

I updated the game today with a probably sound fix, so if you have time, download it again and let me know if that fixes it (version 1.11)


#34

1.12 is new version, redownload to get it.


#35

For some reason I can’t post…

I was getting a crash on 1.11. I’ll try 1.12 when I get home tonight.

Haha…it won’t let me post the error message…maybe it thinks its a virus or something?

FMOD error! (55) (failed playsound) A call to a standard sound card driver failed, which could possibly mean a bug in the driver or resources were missing or exhausted. :…\GUI_sounds.(cpp) 306 (There are no more files.
)

It wouldn’t let me post the file name GUI_sounds.(cpp) without adding the () around the cpp


#36

Dang, that’s two people who have this. I hate sound cards :smiley:
Was it the very first sound it tried to play? or any specific sound? I should point out that this isnt a really dopey mistake by me, it is working fine here on my test machines. it must be a card specific thing, but I should still be able to fix it.
Any more information, or snippets from debug files are most appreciated.


#37

I was just clicking through the player portraits when the crash happens. You can click on any menu buttons about 60 times and then the crash occurs. Creative updated their drivers on 6/25, after like2 years, so I don’t know if its the new drivers or what. So I guess its just playing the defult opening song when the crash occurs? I actually don’t recall any sound playing at all, it just crashed after about 60 menu clicks. I’ll test more with the newer version when I get home from work. I looked in the debug text, but I’m no programmer so I didn’t see anything in it that looked like a crash log/error message, but I will send/post that as well later. Thanks Cliff.


#38

It sounds like creatives drivers are just…poor. I’ve been talking to the people who make the sound engine, and may have a solution, so I’ll put together a test version of the game to see if that fixes, and email it to those affected.


#39

Why is the install file and the game executable named the same? It took me forever to figure out it wouldn’t install because I was trying to install the game in the same folder as the install file.


#40

And I’m the other one !

Read about posting error messages after sending the email to you , sorry :blush:

Same/similar prob as Dirwulf. Selecting, or trying, to choose a player. The gui cursor and game just froze. Didn’t count mouse clicks tho.

btw, the zip you sent is missing the fmodex.dll :open_mouth:

I re-installed 1.11 and all was fine :smiley: