Game won't go fullscreen


#1

When I try to start Democracy 3, the game loads in windowed mode rather than going fullscreen. The window is too long and too narrow, so it doesn’t fill the full width of the screen and the bottom part of the game is cut off, making it unplayable.

I’ve tried uninstalling and reinstalling the game, with no luck. I’ve also tried changing the launch options to ‘-fullscreen’ as suggested for similar problems on other forums, with no luck either.

I’m playing Democracy through Steam on a MacBook Air running OS X 10.9.5, and have no mods installed. Until recently I’d been running this game with no problems at all. Has anyone got any suggestions on how to fix this?


#2

This isn’t likely to help you. But I’m having the exact same problem. Maybe one of my failed attempts will help you. This is copy+pasted what I posted in the steam community forum.

I used to play this game all the time so I think the new update messed everything up.

When I launch the game, it opens in a very small window in the upper left part of my computer screen. I’ve tried pulling at the corners of the window. I’ve tried pressing ALT+Enter. I’ve tried going into the game properties and entering -fullscreen as a launch option. I’ve tried opening Steam in file explorer and checking the box to override the DPI. Nothing has worked. I can’t find another fix online to try.

Please help. I love this game and I’d really like to play it again.


#3

I too have tried to emulate your challenge with the game not playing in full-screen. Sadly I did not have the same result.

Both Democracy 3 and Democracy 3 Africa loaded in full-screen for me. I did however notice that Democracy 3 Africa changes the Aspect Ratio of my monitor to 16:9

I am running at 1920x1080 resolution on a 50 inch monitor.

The only suggestion I have is trying a different resolution? They are both awesome games and well worth the play.