Game won't start on linux : "Could not set video mode"


#1

Just purchased GSB from the Humble Bundle 4. version.txt says 1:56:0

When trying to run it under Ubuntu 11.10 64bits, a dialog windows appears saying “Could not set video mode”.

My Machine is a DELL 5510 laptop, with intel integrated graphics. I got this error with two external monitor plugged in, or with the laptop’s integrated screen.

I tried both X86 and X86_64 bianries, and I also tried to launch the game as root, but the results is always the same.

I am willing to provide any additionnal information, trace, etc…


#2

I have the same issue.

cat /etc/issue

Ubuntu 10.04.3 LTS \n \l

uname -a

Linux *snip computer name* 2.6.32-36-generic-pae #79-Ubuntu SMP Tue Nov 8 23:25:26 UTC 2011 i686 GNU/Linux

I’ll provide any necessary logs. Bought it from Humble Bundle 4 and was hoping to play it on my Linux box. :-/

@cliff: What Linux distro did you compile/design this game for? I am running the same version of GSB as remi_pan.


#3

Okay so far I’ve got the game to give a Segmentation fault instead of that other error. I continued looking around the forums and found a user talking about prefs.ini.

So I ran

strace ./GSB.bin.x86 &> output.txt vim output.txt
I searched for prefs.ini in the sytem call trace and then found it’s located at ~/.positech/GSB/prefs.ini. I edited that and set my options to a resolution smaller than my current resolution and set the preference to windowed mode. Here is a sample prefs.ini with a few resolutions for those who don’t know how to calculate the proper resolution.

[prefs] #width = 2180 #height = 1440 width = 1024 height = 676 #width = 800 #height = 528 windowed = 1 sound_channels = 200

I no longer get the “Could not set video mode” error but now get Segmentation fault. I’ll run another strace and see if I can figure out what is wrong.

For a reference for anyone reading this I have two monitors running in TwinView on an nVidia card. Here is my detected resolution using xrandr.

$ xrandr Screen 0: minimum 2720 x 1024, current 2720 x 1024, maximum 2720 x 1024 default connected 2720x1024+0+0 0mm x 0mm 2720x1024 50.0*

For the segmentation fault issue I’m going to the following thread where it is already being investigated with like architectures.
positech.co.uk/forums/phpBB3 … =21&t=6831


#4

I had this error on Arch Linux 64-bit. Aside from some missing libs (libpng-12 and libjpeg.so.62 – both in AUR) its pretty easy to get going.

I edited the prefs.ini file and changed my resolution to 1920 x 1080 and it worked. It seems to autodetected your max resolution but gets confused by dual monitor configs. I think if you just set this to something your default monitor can actually use this error just goes away.

Cheers


#5

if your machine does not support a screen height of 768 or mroe, be aware that you are likely to run into interface issues at some point. The game does not support video resolutions with a height below that.


#6

What is AUR? Also I have both of those packages installed (including libpng12-0, libpng3, libjpeg62 packages).


#7

Hello all,

I’m the one who did the linux port. (yeah yeah it’s my fault :smiley: )
Aggghh… the bane of dual monitors… salsadoom, what video card are you using in your dual monitor setup? and are you using propriatary drivers? (e.g. nvidia with twinview?)

And I’ll get the libjpeg and libpng files included in the next build. Also can I have MD5s of the GSB.bin.x86 and GSB.bin.x86_64 files. And tell me which install method you used (tarball deb, etc). Thanks.


#8

OK everybody… There is a new binary I just submitted that fixes a number of issues affecting 32bit builds and some newer distributions. It should hopefully be updated sometimes soon on the HIB site.


#9

Thanks for the quick response to this issue, urkle!


#10

When running on netbook (1024x600) after installation you get by default a “Could not set video mode”. After editing the prefs.ini to 600, I could start the game. The resolution is enough.

So you might want to adjust the default prefs.ini to use 600 as the minimum y.
There are quite some netbooks around.

By the way: runs smoothly on my Toshiba NB550D with AMD C-50 APU


#11

Hey, I’m not sure if you broke something new whilst including the update. I’m running x64 on dual monitors (ATI, open source drivers, system76 machine) and the game goes bezerk with my video settings as soon as I try to customize a ship (or click any of the menu items, for that matter).

Any hints as to how to get this running?


#12

Thanks for the hard work urkie. Unfortunately I’m in the same boat everyone else is in, game wont start. I’ve tried using both the .deb and the tar installers for version 1.56 but neither seem to work. Fortunately the game does work on my windows partition so I know my hardware supports it. Currently running a nvidia 445m laptop card under propriety drivers on Ubuntu 11.10 32 bit. Looking forward to giving this game a run through on linux.

Cheers,

Raven


#13

Hi,

I too have problems. I’m running 64 bit Ubuntu 11.04 on a Toshiba netbook NB250.

uname -a says

Linux singularity 2.6.38-13-generic #52-Ubuntu SMP Tue Nov 8 16:53:51 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

I was getting the cannot set video mode error so I edited my prefs file and set the resolution to 1024 x 600. Now, the game starts with the intro screen but quits without an error message after about 1/2 second.

Has anyone had this issue and resolved it?


#14

I’m also having the same problem.

I believe I’m ok screen wise, I’m running at 1366x768, but I’ve also tried at the other 2 x768 resolutions.

stuart@beavis:~$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1366x768       59.6*+   50.0  
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  

I’m using the latest version (downloaded today), and I’m using the shell version of the installer rather that the tgz.

stuart@beavis:/usr/local/games/GSB$ cat version.txt 
1:56:0

The MD5sum for the binary is

stuart@beavis:/usr/local/games/GSB$ md5sum GSB.bin.x86 
022caf87c2a1252f348702995afd076c  GSB.bin.x86

according to lspci, my graphics card is one of these:

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

and I’m trying to play the game on a Lenovo Edge laptop, running Ubuntu 11.10

I also have a 180k strace of what’s going on if that would be any use to you.

Let me know if there’s any more info that might help, I’ve played this game on my Mac and I’m eager to be able to play it on Linux as well!

EDIT: Here’s a bit more info on my video card:

stuart@beavis:/usr/local/games/GSB$ sudo lshw -C video [sudo] password for stuart: *-display description: VGA compatible controller product: Core Processor Integrated Graphics Controller vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 02 width: 64 bits clock: 33MHz capabilities: msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:42 memory:f0000000-f03fffff memory:d0000000-dfffffff ioport:1800(size=8)


#15

Yes, the Strace would be wonderful…


#16

Here you go, zipped down to 18k.

Hope that helps.
GSB-strace.zip (18.4 KB)


#17

Ok, it looks like you have a dual head setup don’t you? As the strace shows the game was trying to set a game resolution with a width of 3286 (your desktop width) (look at line 1203)

Go edit your ~/.positech/GSB/prefs.ini and set a sane resolution in there and see what it does. (I have more adjustments to the code base to hopefully prevent this nonsense from occurring)


#18

I encountered the problem with both twinview (which shows two monitors as one giant monitor) and Xinerama (shows two monitors as two separate desktops) using nVidia proprietary drivers.

I modified prefs.ini to be windowed with a normal 4:3 resolution.


#19

Spot on!

I’m humming the Plantets Suite to myself & deploying the fleet right now!

Thanks for your help.