graphic bugs on visual interface


#1

Hi,

i’ d like to try to describe three bugs (graphic). i installed the last drivers. i run on vista premium familiy 64 bits ; my display is samsung syncmaster 223bw, graphic card NVgeforce6200.

  1. when the game runs in full screen (wether my resolution screen is 1024/768 or 1280/960 or other), the mouse pointer moves slowly (jerky)
    so i need to play windowed.

  2. on the main screen in the game, when the mouse points on an icon (to get detail on links with other icons), this icon is hilighted and becomes bigger (this is normal) at an acceptable speed rate (normal too !). the problem is : THEN when i mouve the mouse elsewhere, the icon becomes smaller at a very slow rate (not acceptable for a pleasant playable game). and THEN every other icon pointed at will become bigger at the same slow rate. the slowdown only happens after i have pointed at least one icon. This means that in a game i begin or load, the first icon i point at will hilight OK, all the following not.

surprisingly, this bug does not happen in the tutorial when the 3 kinds of icons are explained.

  1. when a try to change the amount of money used for a policy, i click on the small button at the bottom of the screen (whick makes amounts change). problem : i click on the new position wished for that button, but the button still moves toward my mouse pointer when i move the mouse elsewhere (ie top right to close the policy window). Sometimes my click will fix the button to the desired position, but often it will not ! so it is very difficult to set a new amount for a policy.

So all this is very annoying for an interesting game which depends strongly on a good graphical interface.

PS : i tried to attach the debug files but it is impossible to attach .txt files or files without extensions…


#2

I think you are describing an input related bug more than anything else. How much memory does your card have? I suspect its sufficient to run the game fine, it sounds like something is interfering with mouse input. Do you have anything on the PC that might be ‘hooked’ into the mouse? drivers for a graphics tablet maybe? Its also worth running a full spyware and virus checks. I’ve seen this happen on someone’s machine (on another game) where they had a keylogger installed by a virus.
If possible, could you download the free version of fraps (fraps.com) and see what frame rate you get fullscreen? I suspect its pretty high, which would suggest an input, rather than a graphics problem.


#3

thanks for your fast answer.

  • my graphic card is 256 Mo
  • i can’t see any device or driver related hooking the mouse. i have a gamepad on USB.
    i checked for viruses and malicious programs yesterday (PC Cilin) and all was OK
  • in full screen, fraps tells me that :
  • on the welcome screen - Roosevelt and Staline picture… i get 75 FPS
  • on the main game screen i get 20 FPS
  • on any other screen i get 5 FPS
  • when an icon is growing, i get 5 FPS
  • when the icon is stabilized hilighted i get 2 FPS.

i dont’ care playing in windowed game. the FPS is better on the various screens, except for the icons hilighted. in windowed game, i can’t have FRAPS tell me the FPS (no value is visible).
Does this help you ??


#4

Hmmm. your FPS seems very low considering the memory on your card. Could you email me the file called ‘drawdebug.txt’ to cliff At positech.co.uk.
Something must be slowing down the graphics for you somehow :frowning:


#5

i have the same exact problem. makes the game unplayable. I’ve tested the program at work and the problem is specific to my laptop with windows vista. my work comp has windows xp. i tried to change “compatibility” in the shortcut properties but no improvement. this seems like a great game, but…

p.s. i get the exact same issue with the demo for rock legend. :frowning:

hope someone can help me.


#6

the problem doesn’t come from Vista as i experimented this bug on a vista 64 bits premium computer.
recently i changed my motherboard, processor, graphic card (before gforce6200 AGP, now ATI2900GT), memory, and installed the same vista premium 64 bits…and it works !!


#7

Set force fallback to 0 under config, open it up by using a word document program.