Graphics Problem!


#1

Hey, just played the demo today and must say I was highly interested in getting the game, so I bought and downloaded it. However, when I installed and updated it, I went to run it but the graphics are extremely glitchy and just basically messed up! It’s weird pinks, greens and purples, the mouse cursor is leaving a permanent “shadow” if you understand me, and most of the backgrounds only cover half the screen.

Very weird seeing as the demo worked perfectly!

Any help would be greatly appreciated!


#2

Damn. this latest graphics tweak has screwed things up on some intel cards. I’ll revert it today for a new version.


#3

I downloaded the new patch to fix the problem but it comes up with the following when I try to install it:

“Error. The setup files are corrupted. Please obtain a new copy of the program”

Tried downloading it again… same error. Am I doing something wrong?


#4

sounds like you need to redownload the entire game again (re-use the original link).


#5

I’ve had the same problem as above, and when i tried to install the patch it told me:

“Patching Process Failed”

Have tried re-downloading the game but i got the same problem. Any thoughts?

Cheers.


#6

Is this with an intel video card?


#7

It is, yes.


#8

Hi, I can’t find your order from your email address. can you email me your order details?
Thanks, (cliff AT positech.co.uk)


#9

I still have a problem. I downloaded Democracy 2 today, and it’s version 1.13 full-- the latest version. But I still have the same graphics problem as earlier mentioned-- the mouse still leaves a “shadow” and the background looks terrible!

Can you fix it?


#10

Exactly the same problem here, paid for my copy today after trying to demo and enjoyed it but got version 1.13 downloaded today and got the unusable shaddow effects making it unplayable! Please help I’m eager to get started! :laughing:


#11

I will investigate this immediately. Do you all have intel video cards?


#12

Hi, I have emailed you, let me know if that fixes it.
Thanks,


#13

Yes I have an Intel graphics card in my computer.
Not sure if the fix was directed towards me or another posted, but don’t seem to have received an email with a fix to test.

Thanks


#14

It looks like the fix I tried worked, so yet another patch will happen today :frowning: and that will finally fix it.


#15

version 1.15 fixes this now