GSB: Game wont start on XP64 (solved by downgrading to 1.59)


#1

Greetings!

I just got GSB on Steam, but I have a problem with the game: When launching it, GSB.exe will start and just run in the background, eating a single CPU core continuously without ever terminating. There is no GUI or splashscreen or whatever showing up. The last time I saw something like this was when trying to run the new XCOM on XP x64 (which required a binary hack and stub DLL workaround, as it was calling NT 6.x specific file-related functions, [see here]. XCOM ignored Microsofts compatibility library for this, so it had to be hacked so the calls would be redirected to the correct DLL on both XP and XP x64).

However, I have found people on this forum who obviously have been running the game on XP x64 just fine, so I’m not sure whether the OS is really the problem (maybe an incompatibility was introduced with a later patch?!). Here is my configuration:

  • Windows XP Professional x64 Edition SP2 (fully updated)
  • 2 x GeForce GTX 580 in SLI, driver 301.42 WHQL (Edit: Updated to 314.07 WHQL, no difference)
  • 2560x1600 screen resolution
  • Creative Labs X-Fi XtremeGamer, driver 2.18.0015

Is this because of the game being incompatible with XP x64 in its latest version, or is this something else? Has anyone else encountered this kind of behaviour, and if yes, can it be fixed?

Also, if there is any way for me to provide additional data (like maybe running the EXE in a debug mode or something?), please let me know how to do that.

Thanks!

Edit: I just downloaded the demo of the game to see if it would behave differently. And well, the demo works just fine, no problems at all. It’s just the full version that seemingly doesn’t want to run… The demo version seems to be 1.50, full version 1.62.

Also, I now checked out the supposed locations of the debug log, but the full version does not even write one. It also does not create its folder in %HOMEPATH%\My Documents\My Games or %HOMEPATH%\Local Settings\Application Data\My Games, but the Demo doesn’t do that either…

Can I somehow get an older version of the full game to try that out?!


#2

Greetings Grand Admiral Thrawn and welcome to the forums.

After reading your detailed explanation, at this point in time I can think of two most possible situations:

  • GSB did not install correctly. (Use steam to “Re verify” the installation)
  • GSB is being blocked from running because it is trying to access the internet. (Bit harder, check permissions in your OS, Anti Virus etc)

If either of these 2 options don’t work we can move to more radical solutions like:

  • Run GSB.exe outside of steam.

#3

Thanks for your reply!

I have verified my game files in Steam and also re-downloaded / re-installed the game already, to no avail. I have also tried to run the game with full administrative privileges, so I would assume that NTFS permissions shouldn’t be the cause. For AV i have Avast, but I haven’t tried to disable it, I will try that today in the evening.

About the network: My local workstation (where the game runs) only has the XP firewall, so it does not filter outgoing connections. My router is also a Windows machine doing NAT with WinRoute Firewall. That firewall also allows all outgoing connections. There is no other router involved (direct LAN connection to an SDSL extender…), so usually I can connect to any host on any port anywhere on the internet.

The game doesn’t require any listen ports for incoming connections from the outside right? If YES, that could of course be a problem then.

Edit:

Ok, i disabled Avast Antivirus completely for another test (that I ran with administrative privileges again). Same problem, no change. So this is all I can see happening here (after Steam shows me the serial number of the game, also I haved masked out the other processes running on my machine):

The 8% CPU load are constant. That’s exactly one CPU thread/core on my machine, as it’s a hexcore with hyperthreading (12 logical CPUs, 100% / 12 = 8.333*%).

So, I do not know what else to try on my end. If you could help me with the “radical” method of running the game outside of steam, I’d be happy to try that. Thanks for the help.

Edit 2: Hm, I just tried to run the game with Steam not running. Steam does not automatically start up as usual with Steam/Steamworks titles. GSB.exe running in the background again, like before. I’m beginning to think that this is not related to Steam. Maybe some patch really broke XP x64 compatibility… But it’s not possible to patch to a previous version I guess?

All ideas are welcome. :slight_smile:

Edit 3: GOT IT! Patches were a bit hard to find, but I got 1.59 from [here], installed it over my version and boom, it works! I disabled Steams auto update feature for the game, so nothing gets overwritten. I do need to launch the GSB.exe from outside Steam though, as the game will otherwise download a newer patch for updating itself instead of just launching. So far, 1.59 seems to work fine that way. I am now quite confident that >=1.6x is broken on XP x64. However, I have only one XP x64 machine, so somebody else would need to confirm this.