GSB under WINE


#1

I just tried running GSB under WINE in Ubuntu 8.04 and it works remarkably well! I think it almost runs better under Wine than it does under Vista. The only thing that seems a bit off is the speed during battle at 1.0x. It seems a bit faster, but that may be because it seems a bit sluggish under Vista overall.

Anyone else try it out under Wine?


#2

Tried it on Wine under Ubuntu Jaunty (9.04?) here, it’s running like a charm so far.


#3

Oh yeah. Works smoother than XP in Ubuntu 9.04.

Two issues:

  1. The cursor starts to drift diagonally down and to the left if I touch the mouse pad
  2. I set the windowed mode wrong so that now I can’t see the battle button. LOL

#4

Hopefully this is useful to anyone who comes across this little niggle:

Looks like you need to run the GSB.exe file with wine while you’re in the Gratuitous Space Battles directory. Trying to run the executable from any other directory gives you the following error:

“Failed to find race:…\src\SIM_Race.cpp 95”


#5

The executable I ran by putting it in “WINE C:” but to run the game I just start it from the WINE menu.


#6

I find the game occasionally starts ignoring my mouseclicks on deployment, but saving the deployment regularly and going back to the main menu and back into deployment avoids that being a problem. Otherwise everything works absolutely fine. Kubuntu 9.04, latest repository version of Wine. Game’s installed to D:\games-wine, where D: is pointed at my storage disk in Wine’s options. Game starts from the filesystem, from the Kickoff application menu, or from krunner.


#7

Yeah I started getting the mouse-click thing too. During deployment it will just stop responding and you can’t even click main menu or drag a ship to a new position. Hitting [esc] brings you one screen back and resets it, so your tactic of saving your deployment often is a good one.
I play it more often on my windows partition but I might change that if a future patch fixes that. Playing in windowed mode takes care of the drifting cursor. It isn’t really designed for Linux so I don’t really have a beef with it. Runs pretty smooth for Wine not directly supporting it.


#8

Hi,

I’m on Jaunty too.
Do you have problem when clicking on escort the games throws out an error and crashes?
I have wine-1.1.29, I will try in crossover and cedega too I think…


Regards GammalGet


#9

Confirm on both Crossover 8.0.0 and Cedega 7.3.2…
Well, then I wont press the escort button again :slight_smile:


#10

Works nicely for me under Ubuntu 9.04 Jaunty also (like Democracy 2 … whatever Cliffski is doing, he’s doing it right :slight_smile: ). I do see the same bug as Sentynel noted above … occasionally it stops responding to mouse clicks in deployment mode, but saving regularly and pressing, ESC, then reloading the deployment works around this. I also occasionally loose sound, and need to restart the program to fix it.

I had to play around a little to get the screen resolution set properly so I could witness the battles in fullscreen glory on my (biggish) TV without any edges cut off. I settled on running Wine in fullscreen mode (not windowed), and set the game resolution and my screen resolution to 1600x1200. Okay … think I’m going to go play some more now (I’ve only beat Sirius on easy so far … practise, practise, practise …)


#11

Has anyone here tried to play with the EEPC 701?


#12

Teiman: Unfortunately I doubt it would work very well on an EeePC 701 unless you plug in an external screen, since the LCD on that model only goes to 800x480 resolution. From the GSB docs: “Your video card must support a minimum screen height of 768 pixels. Some smaller netbooks do not support this and will not run the game”.

I have an EeePC 701 - I might get a chance to give it a try with an external screen this arvo, and I’ll see if the Intel GMA 900 video can handle it.


#13

I have had a go at running GSB on the Eeepc 701, but wine always throws up the error “module type not found -> fighter power:…/src/SIM_ShipModuleType.cpp 279”. Any Ideas?

EDIT: Note, I am in the GSB directory at the time.


#14

I had a chance to try running it on the EeePC 701 under Wine today (EasyPeasy 1.1 - an Ubuntu derivative), with my EeePC plugged into a large external screen at 1980x1050 resolution. The title screen loads and the music starts, but the bottom is cut off so I can’t see the menu buttons, and there is no mouse pointer. I also tried using winecfg to “Emulate a virtual desktop” of 1024x768, or allowing it to run un-windowed fullscreen. Neither helped - it always seemed to try and run fullscreen. There was also an occasional strange screen flicker while Wine was running. I did not see the “module type not found -> fighter power” error, but I wasn’t launching it from the console.

Overall, It had a bit of a sluggish feel about it, even though I only saw the title screen. This makes me think that the game may not run very well, even if I could somehow manage to get it past that point. I think I’ll give up on the EeePC 701 idea for the moment - nice idea, but luckily I have other options to play GSB.


#15

i am using playonlinux(opensuse 11.2,x86_64,Nvidia,Alsa,wine-1.1.39 CVS),seem cann’t run it,i have installed directx9.0c aug 2009 on the wine,still got this error : “failed to initialise 3D Engine:…\src\Game.cpp 288”,i even have configured all of the GSB.exe dll import requirement to wine config,mostly it’s d3d9.dll,d3dx9_41.dll,dinput8.dll,GDI.dll.strange still cann’t run! :(. Anyone can post a tutor for playing on linux?


#16

I’ve been trying to get it running on OSX 10.6 with Wine and Winebottler, but no luck sofar. Had to edit my .cshrc to have it find wine and get cabextract trough fink. Now winetricks at least starts.


#17

Running GSB 1.35 fine* on Ubuntu 9.10 with their Wine 1.01 package. I’m a Linux noob so all I’ve installed are the recommended updates and a few MacBook specific packages.

The mouse pointer / cursor and click issue were present for me in the GSB demo version (1.23) but are not present in the full 1.35 version, which was a pleasant surprise. Cliffski should consider releasing a new demo version.

*Now if I could just figure out how to get the manual to open and turn on the sound :slight_smile: