GSB won't start


#1

Whenever I try to start GSB I get an error which says “ERROR - FMOD[Failed to init FMOD] (58) Error creating hardware sound buffer.
:…\src\GUI_Sounds.cpp 614” This has only been occuring since the latest 2 patches and I suffered no problem before, I have tried doing clean reinstalls twice however each time, I suffer the same problem. I run the 64-bit version of XP which may be what’s causing the problem, however prior to the 1.05/1.06 patches it never happened, and I don’t see why this should affect it now. Trying to run it in compatability mode for XP does nothing either. I tried searching the forums for the error, but found nothing, so I don’t know if I’m the only person suffering from this problem and it’s my machine that’s causing it.


#2

I had a similar problem on Vista x64 after patching to 1.06. Application wouldn’t start.

My solution was to uninstall the game, download the latest version and install it. Patching manually didn’t worked also.


#3

I thank you for your reply, however as I stated, I have tried doing a clean install with the most recent version twice, and neither attempt has had any effect on the problem.


#4

Hi this is a sound engine crash that implies something screwy relating to the set-up of sound drivers or hardware. You could try fiddling with a number of things here. If your sound control panel has a slider or options for hardware acceleration, changing their current setting may well fix it. It may also be affected by whatever is currently selected as the speaker mode (headphones/speakers etc). From what i have seen, this can sometimes cause a screw up where the sound driver thinks a certain option is selected and windows has other ideas, leading to this crash.

edit: For example, in some cases you can select 7.1 sound in the sound control panel or in the driver properties, even though it doesn’t actually support it, and that can cause this.


#5

Thank you for the help, however after chaging my speaker settings to “Desktop Stereo Speakers” instead of Surround, I no longer get the sound engine load error, I now get a series of 4 errors:
9/9/2009 - 17::10 - D3DERR_INVALIDCALL
9/9/2009 - 17::10 - CreateDevice
9/9/2009 - 17::10 - D3DERR_INVALIDCALL
9/9/2009 - 17::10 - software vertex processing failed
9/9/2009 - 17::10 - Failed to initialise 3D Engine:…\src\Game.cpp 289

Which are slightly more worrying. I suspect that the sound error lies with your changes to the “11) Changes to sound engine initialisation to possible correct low sound volume bug”, however I see no probable cause for this problem. Is there any way to have a version 1.04 which will not update until you can find a way to fix this ,please? I will continue to assist in any way I can. My PC has the following specs:

Abit KN9 Motherboard
AMD Athlon 64 X2 5200+
4.0Gb RAM
ATI Radeon 4870HD
160Gb HDD
DirectX v. 9.0c (4.09.0000.0904)


#6

This is something more fundamental going wrong. The game is failing to start up directx, Have you maybe updated graphics drivers recently? The crash you are getting is before the sound engine even starts, which is weird if it suddenly started happening. If you switch the sound settings back does this error then go away?
I cant see how, if it does. That would be ultra weird.


#7

That’s bizarre. When I put the sound settings back I now still get the DX crash, not the sound crash, I don’t think I changed anything other than that.


#8

Thats what I suspected. It might be an unstable video card. Definitely reboot from cold, and I would advise getting the latest drivers for it, and checking other games work. If everything else is playing up, you might need to reseat it (take it out physically and put it back in), because it sounds unstable.


#9

It’s odd though, because other things have always worked perfectly fine, and I’ve had this card for a while. It also seems too strange for this to be coinciding with another crash on load error, when before the patch was issued it had worked perfectly. Don’t get me wrong, I’m not blaming you for anything, it just seems… peculiar. Doing a new clean install does nothing, but I no longer get the sound error, even though I’m back to surround speaker settings.


#10

I have fixed the problem. I didn’t realise that there was a file in My Documents/My games. Deleting this, and setting my sound to Desktop stereo as you suggested earlier, seemed to fix all the problems. I think the problem was that it was trying to load non-existant settings, from the pref.ini, and that meant that the Graphics engine couldn’t start. I think clearing this allowed it to create new settings. Regardless, it is now fully working, I just wish I had known about the files earlier.


#11

Aha, well it’s good to hear that the game is now running.