Help needed with DDS icons


#1

I’m trying to make a mod and am stuck on getting an icon working in-game for my new policy.

Aside from the icon my mod seems to work fine.

I have a jpg icon that I am converting to .dds using ati’s compressonator tool using dds compression dxt1.

The icon looks like this

but in-game all I get is a black square…

The icon is in location Democracy3/MyMod/data/bitmaps/policies/ and is named: icon_cctt.dds (I imitated another mods file strucure and naming convention)

the ‘name’ field in my policies.csv is set to ‘cctt’

Where am I going wrong? There is no info in the official modding guide to point me in the right direction. But I did see that some other mods have icons that are blank white files??? yet the icons work fine in-game?

Any help will be gratefully received!

Just for those interested my mod will add a policy called ‘Cyber Counter-Terrorism Team’ that will allow you to fight the ‘Cyber Warfare’ situation.


#2

OK so I’ve played with this some more and had a margin of success.

I found a tutorial for creating dds files for use as icon textures in some other game http://forums.civfanatics.com/showthread.php?t=459392

, and my result looks like this:

[in game]

As you can see it has the very faint outline of the icon.

I did do a comparison with one of the game’s stock icon files and they have 9 layers whereas my created file only has 1.
Are the extra layers some kind of alpha mask?
My dds does have an alpha anchored layer which is kinda working, and I did the alpha colour replace with black as my starting png image was white on black background.


#3

Hi, this may may not help but when I tried to export my DDS (on GIMP) from a greyscale file I got a similar problem, when I used an RGB file it worked fine.


#4

Thanks for the reply Chromeo, I’m fairly sure that the file was setup as RGB (this was mentioned in the tutorial I was following) but I will make sure to double check this and hope that it fixes the issue!