Help please! Game crashing upon choosing to quit a battle...


#1

Hi guys

I seem to have a problem and I’m completely stumped…

I created a new turret weapon for my race and added it to the game. No problems.

If I have a battle and let the battle play out till the end… again, no problems…I can go back to the menu/fleet deployment screen without incident…

However, if I decide to quit the battle before it’s over, I get the ‘clunk’ noise and the game crashes! I can’t figure out why this happens… ( T_T). It’s definitely the new turret… because if I remove it, the game lets me quit a battle without crashing again. The info in the turret specs is fairly similar to other weapons, I can’t see anything that would make it go wrong… any thoughts please?? It’s driving me nuts!


#2

Hmm, thats weird, maybe the icon value on the module file?, or the “name” value? maybe when the game try to show the statistics, something is wrong, check the module file that all the values are correct and withing the logical values… but its really hard to tell… if u cant figure it out, maybe u should post here the module file so we can look at it deeply… -.-


#3

Hmm…

Good call on the ‘name’ value. However I still can’t fix it! No matter what new name I give this weapon, it causes the same error. But if I change the name to match a different weapon already in the game it works…

screams

I’ll keep trying for a little while longer… (-_-;


#4

Dont worry, i had the same problem with Praetorian Industries Mod, the problem comes when you are using custom turrent textures and the names of them are different to the vainilla ones in the code, then the icon = texture value (or whatever) is wrong, you need to put the turrent texture name BUT idk what name, ask that to Darkstar, he fixed my problem ^^


#5

Weirdly, this error doesn’t happen on the other 2 new turrets I made for the game… (-_-;

It seems to be triggered by the statistics splash screen at the end of the battle… don’t know why or how this relates to this custom turret (and not my other custom ones)!!!

  1. Play battle - Win, choose to return to menu/fleet deployment = no crash
  2. Play battle - Hit Escape or admit defeat mid-battle = Crash
  3. Play battle, Hit Escape or admit defeat before any shots are fired = If I select return to menu - no crash, If I select view statistics, crash!

I’ll PM darkstar about it, see if he has any suggestions, thanks people ^^


#6

Isn’t the statistics screen bug due to the method of doing something changing between GSB versions? For the life of me I can’t remember what it is, but I believe it’s related to an entry in the race file. Probably the one that Praetors told you about I guess.


#7

Can u post the module file of the turret that are causing the problem? are u sure the icon value refers to a sprite that is in the modules directory?

If u are not using custom icon sprites, are u sure that u have mapped the turret specified in the turret value ?

Good luck.


#8

Ok guys, this is the current code for the module (yes I know it’s not well balanced… I’m just playing around atm ^^). This is the 3rd custom turret I’ve done, and the other 2 have no issues, just this one.

[config]
unlockcost = 0
lockable = 0
armour_penetration = 30
blasttexture = "turret_blast_red.dds"
category = "WEAPONS"
classname = "SIM_BulletWeaponModule"
color = 6
cost = 150
crew_required = 8
damage = 80
description = "High speed bullet death."
fire_interval = 25
guiname = "Flamestorm Cannon"
height = 15
hitpoints = 100
icon = turret
min_range = 300
max_range = 800
name = "Yoma Flamestorm Cannon"
optimum_range = 500
powerconsumed = 20
salvo_size = 8
salvo_interval = 800
shield_penetration = 80
size = "CRUISER"
sound = data/sounds/yoma_flamestorm.ogg
soundvolume = 1.0
speed = 40
tracking_speed = 1.1
turret_sprite = turret_fstorm
turretsize = 15.0
weight = 180
width = 3.0
slot_type = TURRET
uisortpos = 1121

[dataitems]
0 = cost,DECIMAL
1 = weight,DECIMAL
2 = hitpoints,DECIMAL
3 = powerconsumed,DECIMAL
4 = max_range,DECIMAL
5 = damage,DECIMAL
6 = fire_interval,INTEGER
7 = tracking_speed,DECIMAL
8 = shield_penetration,DECIMAL
9 = armour_penetration,DECIMAL
10 = crew_required,INTEGER
11 = optimum_range,DECIMAL
12 = min_range,DECIMAL

As for the stat screen bug… I haven’t heard of that ^^; , I did a quick look in the support section and saw one about retreating / stats in campaign mode, I guess they could be related? Although they said that bug was fixed now… and I’m sure my version updated from Steam recently… hmmm…


#9

oh, and the race file currently looks like this… (see below). I started off originally copying the ‘Empire’ race file, and have since changed bits and added new turrets etc.

[code]

[config]
name = “yoma”
guiname = “Yoma”
logo = “yoma.jpg”
debrisstartuv = 48
debrisenduv = 64
escapepodid = 0
shield = “vanguard_shield.dds”
description = “The Yoma continue to expand their empire and offer the honour of eternal servitude in their glorious name to all who would challenge them”
repairbotid = 2
contrailid = 2
music = federation_battle.ogg
shieldcollapseuv = 2
defaultnames = warships
guiid = 5
lockable = 0
unlockcost = 0

[turrets]
turret_auto_v1 = empire_turret_auto.dds,turrets_empire.dds,0
turret_auto_v2 = empire_turret_auto.dds,turrets_empire.dds,0
turret_auto_v3 = empire_turret_auto.dds,turrets_empire.dds,0
turret_auto_v4 = empire_turret_auto.dds,turrets_empire.dds,0
turret_auto_v5 = empire_turret_auto.dds,turrets_empire.dds,0
turret_auto_v6 = empire_turret_auto.dds,turrets_empire.dds,0
turret_bull_v1 = empire_turret_gun1.dds,turrets_empire.dds,8
turret_bull_v2 = empire_turret_gun2.dds,turrets_empire.dds,9
turret_bull_v3 = empire_turret_gun3.dds,turrets_empire.dds,10
turret_bull_v4 = empire_turret_gun4.dds,turrets_empire.dds,11
turret_las_v1 = empire_turret_energy1.dds,turrets_empire.dds,1
turret_las_v2 = empire_turret_energy2.dds,turrets_empire.dds,2
turret_las_v3 = empire_turret_energy3.dds,turrets_empire.dds,3
turret_las_v4 = empire_turret_energy4.dds,turrets_empire.dds,4
turret_las_v5 = empire_turret_energy5.dds,turrets_empire.dds,5
turret_miss_v1 = empire_turret_missile.dds,turrets_empire.dds,13
turret_miss_v2 = empire_turret_missile.dds,turrets_empire.dds,13
turret_miss_v3 = empire_turret_missile.dds,turrets_empire.dds,13
turret_miss_v4 = empire_turret_missile.dds,turrets_empire.dds,13
turret_miss_v5 = empire_turret_missile.dds,turrets_empire.dds,13
turret_shellgun = yoma_shellgun.dds,turrets_yoma.dds,10
turret_fstorm = yoma_flamestorm.dds,turrets_yoma.dds,12
turret_super_plasma = yoma_superplasma.dds,turrets_yoma.dds,14
turret_pd_v1 = empire_turret_auto.dds,turrets_empire.dds,0
turret_pd_v2 = empire_turret_auto.dds,turrets_empire.dds,0
tractor_turret_v1 = tractor_turret_v1.dds,turrets_empire.dds,27
tractor_turret_v2 = tractor_turret_v2.dds,turrets_empire.dds,29
turret_plasma_v1 = plasma_turret_v1.dds,turrets_empire.dds,24
turret_plasma_v2 = plasma_turret_v2.dds,turrets_empire.dds,25
turret_plasma_v3 = plasma_turret_v3.dds,turrets_empire.dds,26
turret_ecm_v1 = empire_turret_energy1.dds,turrets_empire.dds,1

[victory_messages]
0 = “The Empire grows and blossoms”
1 = “Life without battle is life without victory!”
2 = “From death comes new life. Well, from the death of your enemies that is…”

[defeat_messages]
1 = “Merely a tactical retreat… at least that’s what we’ll tell Command…”
2 = “This wave has been halted, but like a severed tail we shall regrow stronger and return!”
3 = “There is a sharp sword and an honourable death awaiting your return.”

[crew]
0 = “Rak’var”
1 = “Arlanth”
2 = “Greth’tar”
3 = “Irv’dal”
4 = “Rolkath”
5 = “Morgaltha”
6 = “Eredek”
7 = “Kor’lan”
8 = “Nor’val”
9 = “Draketh”
10 = “Ur’tan”
11 = “Sor’leth”
12 = “Chek’tah”
13 = “Shrilgar”
14 = “Thurkath”
15 = “Zorth’kel”[/code]


#10

Aradia, I strongly suspect that the bug you’re experiencing is connected to the following data in the Yoma’s racial config file:

turret_fstorm = yoma_flamestorm.dds,turrets_yoma.dds,12

There is a known, very negative interaction that can happen when the post-battle stats screen loads. It is triggered if the graphical mappings for your chosen modded turret icons do not conform to what the GSB game engine is expecting. I’m assuming that somehow the path to the correct turret mapping is broken, or that the turret sprite itself is the problem instead.

Much more data on this messy flaw can be found in the excellent “Modding 101” sticky at the top of this forum; see here and a few posts prior to that one. Again, I’m not 100% sure, but call it an intuitive hunch.


#11

I can’t work it out…

I’ve checked that line multiple times, but the names and everything appears to match up. The reference from the module to the line in the race file matches… the names of the graphics files match, I opened them up and they’re not corrupt or anything, and the size is correct. I tried starting the race file again using federation turrets (all the standard ones) then mine at the end, and still the same issue.

It’s 2.30am now so I think I’ll give it a rest for now and go to bed… thanks for the help so far everyone :slight_smile: night night all x


#12

I was going to go to bed but I decided to have one more crack at it…

turns out I was mistaken, TWO of the three custom turrets cause the crash!!! (-_-;

The ‘Super Plasma’ is fine…

The other two are not and cause a crash.

now I’m going to bed…


#13

This is the typical issue that makes all the people get crazy trying to find a solution ^^

Wat parameters do u use when u save your turrets in dds format?? i mean, compression, mip maps, etc… (just in case) and size?

And, i dont think this is the issue but… u should use default turret names format, i mean in the race file -> turret_myturret = turret_myturret.dds,turrets_myrace.dds,4

Out of that, im out of ideas…


#14

Try making the turret unlockable and see if it makes the Fleet HQ screen crash when you go into it. If so, then either map your turret in the federation race file as well as your own race or set the line icon = turret to icon = your_gun_texture.dds .
Hope this works.


#15

YES YES YES YES YES!!!

THANK YOU!!! No more crashes!!!

Thanks for all the help everyone! :smiley: xx


#16

LOOOL… thats the solution i was telling you in the first post, when i said about custom icon textures…

(Dont forget to copy your dds turret file to the module bitmap folder…).


#17

feels like an idiot

Sorry… I completely missed that bit and just meddled with the name value… ( T_T)

goes and hides under a blanket in the corner

Thanks for the help :slight_smile:


#18

That is cuz i didnt explain wat i was trying to tell u. I supossed that u already knew about using a texture icon in the icon value. Anyways, u solved the problem, thats the only thing that matters xD.


#19

Same here, i said the same thing than nemesis xD


#20

feels doubly stupid…crawls out from blanket, digs hole, jumps in hole then covers again with blanket

(-_-;

Sorry guys… I just couldn’t get my head around what you were both trying to tell me…

“Whats that Skippy/Lassie/Flipper…? There’s an error in my code lines??”

( >_<)

Thanks again and sorry for being a numpty (^ ^ :wink: