hopefully simple 'failed to initialise 3d' error


#1

Hi,
I have the ‘failed to initialise 3d’ error which the forum suggests happens occasionally.
Following the advice about prefs.ini and setting resolutions in that hasn’t helped though. For some reason the game seems to be trying to start by initialising a screen with resolution 0x0 :wink:
My desktop runs at 1920x1080
I’ve tried manually editing prefs.ini to set a different resolution (width = 1024 height = 768 at the moment). I still get the following…
Any help much appreciated!

I get the standard ‘failed to initialise 3d’ message

debug looks like:
----DEBUG FILE----
Windows XP detected
GSB Debug File. App version Full 1.47
Desktop resolution is 1920 x 1080
Initialising Direct3D

drawdebug looks like this:

Initialising 3D Engine
Driver : ati2dvag.dll
Description : ATI Radeon HD 5800 Series
DeviceName : \.\DISPLAY1
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
About to Create 3D Device with width: 0 and height : 0
Attempting hardware Vertex Processing
Attempting software Vertex Processing


#2

Hmmm, is this a high spec video card? latest drivers? It sounds like a failur to get the current desktop resolution as a default, but then editing the prefs should override that.
Is this running under windows XP/ Vista? 7? Is it maybe a multimonitor eyefinity setup?
I can’t see any reason why it shouldnt be running ok. Its not under WINE or similar?


#3

Maybe not so simple then!

It is a high spec card. radeon HD 58xx series has been out for about 9 months - I only have one card rather than a 2 or more in crossfire. I updated the drivers the first time I saw the problem so my driver is now the latest on the ATI site (about a month since this driver version was released).

Otherwise Windows XP, not multi-monitor and not running under anything complicated like Wine. In fact this was a fresh windows install when I get the graphics card 9 months ago and it’s still pretty clean.

Let me know what else I can send you to help debug as I’m keen to play!


#4

PS. When I installed the game (via an Impulse distribution) the install created a prefs file. If I move/rename this then the game doesn’t create a new one. I expect the problem is occuring before the check on the prefs file.


#5

PPS. Disregard the last email. The game is creating a blank prefs file if one doesn’t exist.


#6

That should defintiely not be happening, unless your card is insanely low spec laptop style cheapness. Something is definitely wrong with some setting on the video card drivers, or they are conflicting with a previously installed driver. The card doesn’t seem to report the correct capabilities.
Have you tried running that directx diagnostics program?


#7

Obviously, there must be an issue with your current driver installed. Maybe you could try reinstalling the original video driver but if you don’t have anymore the CD, there’s a way to restore it if you’re running on Vista or XP. I couldn’t go into lengthy detail, but you can learn more about problems with video drivers and possible solution that may solve your problem here.


#8

Well I’ve got the game working and I’m enjoying it.

Certainly a driver problem somewhere. I uninstalled everything ati and reinstalled (twice actually because I installed vista drivers instead of XP the first time)!
Then set up the prefs file. Then re-setup my speakers following the advice in another post.
All works now (although I get an error from catalyst control centre when the computer starts so there’s still an annoyance there)