How to change game resolution when GUI not available ?


#1

Hi

The story is as following:

I have Windows 7 in dual screen mode, LG 19’ & Laptop 15’ screen.
When LG LCD is connected it is the main screen.

I’ve setup the game when the LCD screen was connected, played and loved it.
Now I want to play the game on my laptop screen while the LCD is disconnected and can’t - I’m getting some error message (can’t reproduce, will explain).

How do I fix this? Where do I edit the configurations? Tried to look in the game installation directory and haven’t found any relevant configuration files.

To try to resolve this issue I’ve connected a friends LCD and started the game (otherwise it would stuck and won’t display even the main screen). From there I’ve set the game to run in a window instead of full screen mode hoping it will solve the problem, it didn’t. Now I can start the game, window mode bug the created window is too resolution is bigger then my laptop resolution - Hench I can’t browse to the options menu to change it to a lower resolution.

End of story - Cool game, good job, please help :slight_smile:


#2

MyDocuments\My Games\GratuitousSpaceBattles\prefs.ini is where you change it

[prefs] width = 1280 height = 800

etc


#3

Yes, I’ve run into this major bug within 30 seconds of installing the game.

I run a dual monitor setup under Windows 7 (dual 8800gts 640m, dual 22" HD in non-SLI mode) and I always run games in windowed mode… unfortunately when you set this game to windowed mode all of the user interface buttons disappear, so the game splash screen comes up and you cannot do anything further except uninstall and reinstall it to regain ‘fullscreen mode’.

Any patch to fix this massive breakage of the game coming?

Edit:
Using the above suggested fix I was able to reset the game to fullscreen, but I despise being locked in the annoying window (especially since Alt-Tab is notorious for causing crashes).

Edit 2:

Alt-Tabbing automatically engages windowed mode and when it returns it’s a black screen, forcing a shutdown and restart. [b]This is a major game destroying flaw. I can’t believe that QA missed something this insanely simple before release![/b]


#4

Windowed mode works fine here, this is a massive breakage from your computer.


#5

And your suggestion for remedying this is… what?

Likely of no more intelligence than your troll.

Current system:

Windows 7 Ultimate 64 (build 7100)
AMD Phenom II (Black+) quad 3.0 on FoxConn Destroyer MB.
1.25tb RAID, 8gb RAM
2x 8800 GTS 640m (unbridged), 2x 22" HD (1 per card) - latest EVGA drivers


#6

I’m sorry for that troll, but you can’t expect much more when your first posts on a forum are ‘omg this is broken how did you NOT NOTICE BEFORHAND OMG’.
Now I’d say, the issue is with the two 8800s, did you try running the game with only one?


#7

Have you tried to turn off the transition effects and then doing the alt+tab? For me it fixed the black screen error.


#8

As in… go in and rip one out just to play a game?

Sorry, not going to happen.

And, as they’re not bridged (not in SLI mode) and running 1 monitor per card then by default i’m only using the game on one card. I’m just forced to use it in full-screen mode as windowed, no matter what resolution I choose, wipes out the UI icons.

How is this accomplished?


#9

the transitions can be toggled off under the options screen. It’s that gratuitous wipe effect between screens


#10

yes, but you cannot get to options if this happens >_> go to config.txt and change TRANSITIONS = 1.00 to TRANSITIONS = 0.00 that should fix the problem