Image bleed at 2560x1600


#1

GSB looks fantastic at 2560x1600 except for the far right side of the screen, which is only rendered as bars of colors from the rest of the image, as shown in this screen cap : img156.imageshack.us/img156/2742/gsbbleed.png

This is on a 2x 8800GTX system but the cards are not in SLI mode. Relatively recent Nvidia driver although it’s not the absolute latest and greatest. Corruption starts at pixel 2048 so it’s probably just a buffer not being set up large enough? I’m not a windows programmer so I’ll stop pretending to be one now. :slight_smile:


#2

The maps are only 2048 in some cases in world space, so this can happen. I suspect (but cant check as my measley main monitor is only 1920 res) that some of the bigger maps work fine?


#3

Cliffski could you post a list of the larger maps?


#4

Battle of Mexallon II
Conquering Chiarn Prime
The Chaos Nebula
The Multari Gas Giant
Defend Caspian IV
Gravity Well
Lucifer’s Nebula


#5

I’ve checked the maps you listed but sadly they show the same problem. The last 500 rows of pixels on the right side are streaked.

If I zoom in on a smaller part of the map then the problem is still there. The right side pixels are streaked, if I scroll the map to the right the image that is hidden by the streaks does show up and looks normal.

I’ve changed the backdrop of a battle with a 4000*2523 jpeg I had lying around, and the backdrop does show up. However the right side of the screen is still streaked.

I’ve also pulled this data from a file called drawdebug in the debug folder.

Initialising 3D Engine
Driver : nvd3dum.dll
Description : NVIDIA GeForce 8800 GTS Wrong graphics card detectedm, I actually have a GTX280
DeviceName : \.\DISPLAY1
About to Create 3D Device with width: 1024 and height : 768
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
Finished initialising 3D Engine
Initialising Render target of 512 X 512 rt_ship
rt_ship
Initialising Render target of 2048 X 1024 rt_offscreen1
rt_offscreen1
Initialising Render target of 2048 X 1024 rt_offscreen2
rt_offscreen2


#6

Hi. I am seeing this same problem on my system, running at 3840x1024 resolution using a Matrox Triplehead unit; however, at this resolution the problem is even worse - for me, fully half the screen is just streaks. I will try running at lower resolutions and more normal aspect ratios to see if I can pick the point that is the limit, but my money is on 2048 being a hard-coded limit somwhere in the graphics engine. The effect remains constant regardless of how you zoom and pan the view. Zoom right in, and still everything from just right of the screen centre is still just horizontal streaks.

I do hope it is an easy fix that can make it into the final cut, because at these resolutions the action is extremely gratuitous!

I am running on Windows 7 64-bit.
If you need more specific data or testing of this, please just let me know.


#7

I have re-tested with resolution set to 1600x1024 - works fine, although of course it does not utilise the full screen area.


#8

Sounds like you have the incorrect graphics drivers?


#9

Already posted about this exact problem.
http://positech.co.uk/forums/phpBB3/viewtopic.php?f=21&t=2637&start=0

Turning off Gratuitous Shaders in the Video Options solves the streaking problem at 2560 x 1600.
Running at 1920 x 1200 with Gratuitous Shaders turned on also has no streaking.


#10

Nope, I’m running 190.38, besides if I was running an out of date graphics driver i.e. one older than the GTX280 itself, than I would have a lot more problems.