impulse update


#1

the latest update for the game doesn’t seem to be applying in impulse. i have version 1.10. i get no message to update. when i verify the install it tells me i have the incorrect version. i press the update button that appears. it updates. i have version 1.10…?


#2

I’m not sure what update button you refer to, but is that part of impulse? If you have put in your serial code and picked a username, the game will autopupdate outside of impulse automatically.


#3

… i put in my name in the online thing, and i am registered. after doing so, when i booted up the game, i got a blue? bar that slowly moved across the screen. then it said there was some failure. since then, i have uninstalled and reinstalled the game, and tried to update through impulse a few times.


#4

Same problem here. (Impulse lists 1.10b as the version they have on their servers, by the way.)

So after the ingame update - which also crashed on me - I tried updating via Impulse (which obviously didn’t work, since they have an older version). Then I uninstalled the game, reinstalled and waited for the update… which didn’t happen this time. Hmm.

Do you regularly supply Impulse with the latest GSB build, good Mr. Cliffski? I really want to play that survival mode… (and hey, I’m new here, love your games, yada yada yada. Keep up the brilliant work!)


#5

It sounds like impulse is conflicting with the games autoupdate somehow. I’ll investigate


#6

thanks


#7

Impulse is a nice delivery system (I’ve got a couple dozen games through their system), but for cliffsky’s games, I just buy them direct from Positech. They’re usually a couple of bucks cheaper. You know that clifsky’s getting most of the money from the purchase. You still get to download the game as many times as you need to, and I’ve found him far easier to deal with than the folks at Stardock.


#8

True. I prolly would have bought it from the website, but my friend told me impulse was having a sale, so I snapped it up.


#9

Yeah, that ‘sale’ isn’t really a sale, its a discount on the full price of the game, likely $22.95. So in that sense, it’s on sale here too :smiley: The price is the same.


#10

Oh well, I already regret buying from Impulse. >_> But thanks for looking into it.

[However, I payed noticeably less money buying from Impulse (where I got the game for about 13 €) and Positechs delivery thingamabob (which wanted to charge me about 17 €). So there. Being the once-poor-student-and-now-poor-and-unemployed-ex-student that I am, I jumped at that offer.]


#11

Aha! I took a peek into the folder where the savegames are stored and found the downloaded patch file there. Started it, seemed to install fine and then gave me an error message along the lines of “The application could not start because fmodex.dll wasn’t found. Reinstallation could solve that problem.”

Trying now to delete and reinstall the game as well as the patch file, brb. ^^

EDIT: nope, didn’t work. Still the same problem, no fmodex.dll


#12

Yeah, that’s the error message I got too.


#13

Not sure. I got it for 24,723 South Korean Won. The game full price is 28,441 SKW.

The price I paid works out to 20.72 USD. One of the perks of Impulse is it at least lists it in the currency I have to use. The other digital download stores that I have dealt with don’t.

Looking at the positech games, I would have to pay 25934 SKW. So, I saved a buck… feeling a bit stupid and cheap now… :P. Oh, well. Lesson learned. Gonna compare prices a bit more closely in the future.


#14

I think impulse arent’ charging local sales tax maybe?

Anyway, here is the bug:

Impulse works fine and downloads the game, and installs it, and my auto patcher then downloads the patch and runs it fine
BUT
My installer does not know where the game is installed to. It is GUESSING that it is:
c:\program files\gratuitous space battles beta
and under impulse it is NOT. it is:
C:\Program Files\Positech Games\Gratuitous Space Battles
And you need to click the browse/edit button on the patch installer to make sure it is right. Also make sure it doesn’t copy gratuitous space battles beta on the end once you select a folder.
Basically my patcher, unless you correct it, is installing to the wrong folder, so it then won’t run.

The patches are in \MyDocuments\MyGames\Patches, if you need to re-run them.


#15

As far as I can see, there is no sales tax here in South Korea. Thanks for the help.


#16

Gee, thank you so much.

Actually I checked if the patch used the correct folder, but a previous patch attempt created the false directory and installed some files there, so I thought that was the correct one. Facepalm time. Aaaanyway, thanks again. Off to survival mode, yay!


#17

A suggestion, Cliff, would be to have the installer save a registry key that points to where it is installed. That way, patches could just look up the install point.

The only disadvantage of this is that it’s hard to have multiple copies installed at once. But I doubt that’s much of a problem.


#18

found the error: fail post is fail. :smiley:

by the way, thx for this game dude, its realy awesome. :wink:


#19

Yup, the pain is that I use an off-the-shelf installer (inno setup) and it can’t do that without re scripting part of it using python, last time I looked. This takes some fiddling, and is why I haven’t done it yet. I’d love to do it, there are just 100 other calls on the same time right now :frowning: