Install Tribe - Crappy installer...


#1

Why can’t the installer, or update for that matter find my current installed directory. Do I really have to pay attention to where I install a program, every time it updates… Grrr.

So, I try to download challanges, but the “you do not have the content…” whatever warning pops up. How about a check box to save me the hassle. Too much to ask? Searching through challange after challange that I cannot download is annoying.

So I breakdown and buy the tribe, ahhh… the installer. Regardless of which directorY I install it to it never seems to be available in the ship builder as a class.

I know I am missing something simple. So I delete the local content (Steam purchase) and reinstall… no luck. Delete every dammn thing that has to do with GSB and reinstall, then tribe.exe, still no luck, although everything I purchased in fleet is now gone. (yes in the recycle bin) I will restore it to see if I can get it back, but not a big deal really.

Installing this expansion has made me feel like an ass. I am computer literate, dual boot - linux, blah blah. But after 1 drink I am so fustrated with this, I just want to go back to TF2.

Please a quick, “install here” would be so nice. Does it go with the steam folder, or the My Docs/My Games folder that I did not want that it installed anyways. Neitehr works last time I tried, but I am willing to waste some more time.


#2

Extra info - Orginal GSB was bought on steam. The tribe was bought via the Positech site as a download. Had I know it was on steam I would have gotten it there and may not have had this problem. Grr…


#3

Hi, I appreciate how annoying it is. I use inno setup for my installer, and the one feature the flipping thing lacks is the ability to install based on a registry key. Damn.
Anyway…
Steam installs GSB to something like this (check your machine to ensure its right):

C:\Program Files\Steam\steamapps\common\gratuitous space battles

and that is where you need to install Tribe. Of course, that folder already exists, which is fine. If it works, when you look in that folder you should see a data folder and also a new ‘tribe’ folder (and a few other folders and files too).
Then it will definitely work.


#4

Uh, not true Cliff, it does support registry keys. Thing is, it’s just looking for a previous install so that it can read the directory from there; you need to look at scripting to figure out how to read the installation directory from the registry and use it.

See the documentation for Pascal Scripting > Support Functions Reference, four fifths of the way down.

The only thing I don’t know how to do is set the destination path from the registry with scripting. Then again, I’ve not used Inno Setup for almost 4 years.


#5

The result I got from installing to the \Program Files\Steam\steamapps\common\gratuitous space battles did not work. A folder named “tribe” was just installed there, which inside is a “data” folder. FInally I copied the “data” folder to the main data folder, and then the tribe was available.

But I still got the ‘don’t have the content’ when I try to fight online battles. Is there another batch of files needed somewhere else? I am guessing this is a “steam / no steam” issue, since I seem to be the only one? Anyone else having this issue, or am I just really an idiot (could be true… most likely.)


#6

You are definitely not the only person buying one from me and one from steam, there are lots of people doing that. the tribe folder SHOULD be inside the gratuitous space battles folder, alongside its normal data folder. You don’t need to drag any files anywhere, it will NOT work if you do that.
The tribe installer should create that new ‘tribe’ folder, with all its subfolders and also write a file to \data\packages \and one to \data\installs.
If it has not installed those files then there is some sort of freaky permissions problem on windows that is stopping it doing so. Are you the administrator?


#7

Ok, so we are in agreement, I am an idiot. I figured I was the only one. I am admin so permission are not a prob.

I deleted the files that I had copied to the \data folder, the tribe ships were now gone.

Re-ran the installer, and left the ~\tribe folder in the ~\common\gratuitous space battles, and every works!!

This was the orginal location that I installed too. Before I started try to find other locations. At this point I don’t know why it didn’t work right off the bat. I may delete the content and install to a fresh location just to see what could have happenend. If I figure out the simple mistake I must ofmade I will let you know.

Is there a way I can copy/backup my unlocked modules so that after a fresh install I can get back what I had?


#8

yup, just backup the entire \mydocuments\my games\gratuitous space battles folder. Everything user generated goes there.