Internet Update Problems


#1

I just bought the game today and and I love it. However, I cannot get the internet update to work. Everytime I click Refresh the game freezes and I get the error “Httpsendrequesst()failed” . I tried turning off my firewall and pressing Alt+Enter but it is still not working. Are there any other things I should try?


#2

It definately sounds like the Firewall is your problem. Unfortunately not all Firewalls are the same… You might want to find out which ports are needed to be opened (ask Cliffski) and then open them specifically for the game through which ever Firewall program you’re using… Again, sometimes it does depend on the Firewall itself and how much control you actually have over manipulating the Firewall… (so far I haven’t come across any that don’t allow you to open ports though) then it’s just a matter of finding out how the ports are opened within your software. Of course, you’ll want to limit the access to your Firewall and allow only the game to send/receive data through it. Hope this helps a little… sounds confusing, but better to figure it out now because you’ll most likely have the problem with other software games or applications eventually.

Take care.

J.


#3

Thanks for the help. Unfortunately the only options my computer gives me are to add Kudos to the Exempt list, but nothing about different ports. And even when I do add it the same thing happens…and when I turn the whole fire wall off (wouldn’t that HAVE to work in theory?). I’ll fool around with it a little more but hopefully cliffski will read this and come to my rescue. :slight_smile:


#4

very strange. it uses the same port as all web traffic, (80) so it should be fine, the only thing that could be causing problems is other web-related software on your machine. are you running the aol client maybe? aol are well known for screwing up windows internal web access.


#5

Jess, what firewall are you using? You may need to specify that it needs to accept settings from the internet zone. Using ZoneAlarm I checked my settings and it just requires access to see what updates are available. It’s possible, although doubtful, that it may require server rights to actually download. As I said, that is doubtful.

Are you running a comprehensive tool like Microsoft’s Defender in addition to your firewall? It may be blocking it without you seeing it since I believe there is a built-in firewall in the program.


#6

Unfortunately it could be a number of problems but most likely not game related. Cliff was right about the AOL software, and like Eddy asked - which Firewall do you use? Some of the non-critical updates that were released as part of WinXP Service pack 2 could be the problem also if any of them had changed configuration in your WinXP firewall (which is a piece of shyte anyway). McAfee, Nortons, ZoneAlarm, and AVG are quite easy to deal with though. So if you let us know what software you’re using hopefully one of us can help. I’m no technical guru, but I think you’ll find a lot of people willing to try and help. If you do end up fixing it on your own you should definately post what you had to do in case there are other users out there who have the same or similar problems connecting and updating.

Take care.

J.