Is hacking weapons possible?

I put this here because I’m not sure if it should go into Challenges or Bugs, but either way it is important enough everyone should be aware of it.

I recently ran challenge #5191676, and none of my pulse weapons worked, whether they were on cruiser or dreadnought hulls. They simply didn’t fire at all, no matter the range. It’s not a hard challenge per se, once I swapped to weapon configs that didn’t have any pulse weapons I beat it easily, but I think this should be known that either a: someone figured out how to hack challenges to disable certain weapons, or b: there’s some kind of bug affecting certain weapons.

There is no way a challenge can prevent a weapon from firing. If you have a sample deployment that reproduces this I’d love to see it.

If I was gonna hack a weapon so it didn’t fire, I’d definitely do it to a pulse cannon. X)

Just played that challenge, and the following weapons worked fine on my fleet:
Pulse Cannon
Sledgehammer Pulse Cannon
Nuclear Pulse Laser

Sable Phoenix, are you sure it wasn’t just a transient glitch on your end?

I ran the challenge multiple times with multiple hulls, as well as quitting and restarting the program. None of this worked. So far it’s only been that particular challenge that’s been a problem.

Hmm, weird.

Alright, I’m going to say this is some kind of bug. I ran another challenge which I lost two or three times because my ships got into pulse cannon range and either didn’t fire at all or fired one salvo and stopped. Meanwhile the enemy fleet’s pulls cannons worked perfectly.

Hi, can you send a challenge to cliffski that has your fleet exhibiting this bug? (and pls label it something like ‘pulse cannons not firing’.

What orders are you using? Have you tried making a blank hull and putting a pulse cannon on it and use it in your deployment? Also, when you select the weapon in battle, do the targeting lines correspond to ships in range?

Better yet, Screenshots would be nice. (you need to convert the raw BMP to a JPEG or something else to upload the SS to the forum)

It really sounds like corrupted Gunnery AI/Order values in your saved designs.

Under certain circumstances the Order/Targeting Priority system can bug out and it DOES have the ability to make a ship hold fire… indefinitely.

Okay, I sent the challenge to cliffski, but I’m assuming it won’t have the enemy ships either, so I don’t know how it will work. Sometimes a few of the pulse cannons will be firing, but it’s never all of them. It’s happened with multiple ship designs, too, so this fleet is just one example.

Possibly related to this ?

I think targets that are out of range are being selected.

They definitely fired ok for me, did you previously experience it in battles where the enemy had holo projectors?

Nope, this occurred where the enemy had no decoy projectors. It could be I’m just running into the same thing that other people are noticing in the bug thread that yurch linked in the post just before yours.