IS the Campaign Working??


#1

Hi guys, yesterday i decided to install the campaign in my working GSB installation (the one i use to mod in) and wat is my surprise that , i am very dumb or i dunno wats going ong. Just this screen ->

The first, impossible to build any ship. Since its my first campaign try, i only suposse i need pilots for building the ships… but as the CAMPAIGN_PILOTS value say (i suposse it is a bug, thats the variable name) i have 0. And i cant get more than 0 pilots. So, how to build??? the game wont let me to build anything, i tried advancing turns, but nothing happens. Is this a campaign bug??


#2

Helooooo??? No one have any idea?? or it is the campaign so buggy for wat i see???


#3

After a quick search you can find several threads with the same problem, here are a few of them:

Hopefully one will help you solve your problem:


#4

Thx darkstar, almost u have the “honour” to give me something to look into it -.- BUT:

1-. The main problem i have is not the white screen, (look under the image wat i wrote).
2-. I didnt notice the white screen, i thought that was the way it should be… xD. But no, i followed the instructions in those posts u gave me and the white screen still there. Exepct that i didnt reinstalled the whole game, i dont think thats a great solution since it is supossed the campaign should work fine in a regular install.
3-. I cant find any post relationed to the problem i have , its like the campaign is just not working or something is missing and i dunno know wat. BTW I cant find either the variable “CAMPAIGN_PILOTS” anywhere.


#5

I thought the CAMPAIGN_PILOTS was a result of modding hence i would nt be able to provide a solution but only guess as to where you might look, whereas the white screen was a bug that was recently squashed.

If i think of any other solutions i will let you know


#6

Hi, this is definitely some side effect of modding. the solution is is to back up, then delete the whole game, and reinstall it from scratch, and it will be fine. Make sure you remove the \my documents\my games\gratuitous space battles folder, as well as the program files one.


#7

But will the campaign working good after i reinstall the game from scratch even with some mods installed ?? (i will only leave 2 or 3 active mods).

EDIT: Deleted all directories, deleted local content (uninstall) and game reinstalled from scratch. After that, i installed the campaign and the same result. White background and no way to buy any ships (same as before). More ideas O_o (i cant believe its impossible to play the campaign after i bought it…) ??


#8

hmmm… the game is laggy? because seems like the background image is missing or something like that, i ask this because, if a weapon or module has a wrong sprite path naming, the game gets lag when it needs to show it.
EDIT: Nevermind, looking at the picture, there are many errors, maybe the missing background just is one of several errors…
Cliff, what about a damaged installer, or bad data transfer?. One time, with Homeworld2, i downloaded a mod and something similar to this happened, i noticed some weird errors on the files like weird naming, files mixing (something wrong woth the data indexes), missing files etc etc etc, but what I noticed, what is more important to me was a size difference, the file was smaller than it should be, then i checked the download data, the problem was something like a download crash.
I re downloaded the file and it worked perfectly…


#9

Did you delete your savegames and so on from your personal folder, or just the game itself?


#10

Yup i deleted EVERYTHING, the only thing that is out of normal is that my GSB is from steam and the campaign isnt… but i dont think this should be a problem lol.