Keyboard completely unresponsive in game.


#1

I bought GSB through Steam about 12 months ago, played it for a little while and then got distracted by other things and uninstalled it. On a whim I purchased the Swarm DLC today and reinstalled GSB (through Steam), the game loads, the few ship designs I saved are still there (so obviously Steam’s idea of an uninstall is not that thorough it seems) but the problem I have having is that the keyboard is completely unresponsive. Totally.

The mouse works fine, the sound is great, and I can play the first mission no worries, but anywhere where I can type something in (like saving a ship design) the game refuses to see the keyboard and just acts like there isn’t one attached (which is to say, does nothing). The keyboard is working fine, if I press Ctrl-Esc whilst in game I get back into Windows no problem, just no response from GSB.

And that is weird because when I first installed it it DID work fine. I have just tried it in windowed mode, with the same results, Alt-Tab works, pressing the window key brings up the start menu etc, but GSB responses to nothing.

Any ideas? I apologise if this has been answered, I did look through the common problems sticky, and did a few searches for the word keyboard, but came up with nothing.

Specs:
Windows 7 x64
GSB reports a v1.62 in the top right corner windowed mode
ATI 5850, Cataylst drivers 13.1
Logitech Setpoint 6.51 (latest - just checked that).

Any help would be most appreciated.


#2

this is not steam, this is in
C:\Users\user\Documents\My Games\GratuitousSpaceBattles

i suggest uninstalling again, and then do a windows search for GSB and deleting anything that comes up


#3

Thanks for taking the time to reply dafrandle.

Unfortunately that didn’t make any difference. I uninstalled the game via Steam, then did a search for anything across both hard drives that might be related to GSB, and removed all of that too.

Re downloaded/installed from Steam the problem is exactly the same, absolutely no keyboard response within the game. Alt-Ctrl-Del works, Alt-Tab works, I just cannot type anything in anywhere that the game recognises.
The manual finding and uninstalling of leftover directories worked as now the game wants my key again, brings up the tutorial windows, and there are no saved ship files within the game.

I pre-empt any further questions, I am using a standard qwerty layout keyboard (A fairly standard logitech, not their G series or anything). The mouse works fine.

I have looked through both the debug.txt and drawdebug.txt files and the only line that indicates any sort of problem is “GBufferedFile failed to open file” in the debug.txt file. And I’m not sure that is related to anything I am seeing here, it could just be a standard thing.

If anyone has any further suggestions I would be very grateful to hear them


#4

A very perplexing issue indeed.

Question - since you have uninstalled and GSB has asked you to enter your key once again. Can you enter your key manually ? or the keyboard is not responsive for that section as well ?


#5

Thanks for your time darkstar076

In answer to your question, no I cannot enter in my key. In any place that I can find within the game to type something in, nothing happens. Which, as you say, is perplexing.

The keyboard is fine, windows recognizes any system keypresses, its just GSB that seems very stubborn in ignoring me :slight_smile:

I’ll do a quick read up of some basic keyboard shortcuts the game uses when in play and see if they respond, or not, as further testing.

EDIT: Some further results. The “Press any Key” message that appears just before you begin the battle responses to a mouse click, but not to the keyboard, i.e. it stays on that screen regardless of what keyboard key I press, it only goes away hen I click a mouse button.
Pressing ‘U’ during battle is meant to remove the UI from the screen, leaving just the battle, it does nothing for me, confirming that keyboard shortcuts don’t work either. Bugger.


#6

This is rather weird.
I have never come across this issue for GSB - the only time i have seen it is in another game where the Keyboard drivers and the game had some sort of communication conflict. The problem was solved by using some generic keyboard.

Next question - do you have any other keyboards available which you could try ?

Past that, the only suggestions I can think of are trial and error:

  • Validate GSB in Steam
  • Close down all other programs to bare bones operating systems and try again (could be a conflict between GSB and another program - ie antivirus)

#7

Hopefully I will get some time on the weekend…

I plan to uninstall the Logitech Mouse and Keyboard drivers and go hunt down a spare keyboard, there should be a spare 100 or so at work and I’m sure I have a couple at home somewhere. Hopefully that will isolate the issue.

However, one thought does occur… Does anyone know if GSB does anything ‘non standard’ in regards to how it intercepts keyboard input? I use Comodo Internet Security v6, and I’m wondering if it is blocking GSB somehow. Comodo does monitor interrupts, memory hooks, keyboard intercepts (for key loggers etc) so it is another possibility…

I"ll elevate the trust level of GSB within the security program and see if that changes anything if I get time tonight…

Thanks again for your suggestions.


#8

Remember, that you have a long weekend :slight_smile:

I think that is the quickest solution to see if it is in fact your keyboard or not

Not to my knowledge, although Cliffski is the only one that can really answer that.

Hopefully that will solve the problem, that way you can use your keyboard with GSB

Your welcome