Latest Patch


#21

I created one, and it wasn’t used. This is using Vista 64-bit. The game crashes as soon as I try to go into the social events listing. Solo events and classes work OK.

EDIT - Just uninstalled and reinstalled the game. It looks like I now need to run this one as administrator as well. Fortunately, I had the same problem with Democracy 2, so this one was far quicker to troubeshoot. Looks like trying to add in a gym workout session as a social activity didn’t work too well. :frowning: Still no debugdata in the main game directory, though.


#22

I hope this is a good place to post this. I didn’t feel like starting a whole new topic.

Anyway, I bought this game after playing the demo, and everything is great except for one thing. I couldn’t get it to work until I changed my resolution to 1024 x 768. My native resolution for my laptop is 1280 x 800, and it always gave an error when in that resolution. Here is what was in the drawdebug.txt file:

Initialising Direct Draw
Attempting fullscreen mode
Creating Context at 1280 768 32
Forcing Fallback Init
Attempting Fallback Init
SetDisplayMode
DDERR_UNSUPPORTED

In another post you claim it works in 1280 x 800 (you said 1200 x 800, but i think you meant 1280) but it clearly doesn’t for me. Honestly, it’s annoying to change my resolution all the time. Thank you.


#23

In the options screen of the game, there’s a box for “Full Screen Mode” Making sure this is turned off may solve your problem. (My laptop is also widescreen. While the game works full screen, I find the stretching highly annoying…so I use Windowed mode.)


#24

It looks like some laptops (like the ones I tested on) are fine with 1280 768 but some really aren’t. The game is a nightmare to rejig for 800 height, but at 1280 768 it looks ok.
With the next patch for the game I will put in some code to check that res is supported before attempting it. I didn’t realise some 1280 800 laptops couldn’t do it :frowning:


#25

Quick question. The daily job event scripts that reside in \data\simulation\jobevents. I assume within things like “OnTrigger = ApplyEffect(happiness,-0.14,_HAPPINESS_DEGRADE,waiter bad);” , the ‘waiter bad’ is basically just for debugging? It has no effect on the game itself and thus could be omitted entirely?

\jobevents\reporter\reporter_good.txt has “OnTrigger = ApplyEffect(happiness,0.1,_HAPPINESS_DEGRADE,programmer good);” and \jobevents\sales\sales_poor.txt has “OnTrigger = ApplyEffect(happiness,-0.1,_HAPPINESS_DEGRADE,poor sales);ApplyEffect(confidence,-0.08,_CONFIDENCE_DEGRADE,poor sales);ApplyEffect(optimism,-0.04,_OPTIMISM_DEGRADE,good sales);” - which both make no sense in the latter debug field, unless they are of no real consequence.

Excuse the dumb questions, but am still considering my web style Kudos2 editor and am currently discovering what various things do.


#26

That final bit of text is ignored by the game, but it IS stored, and even stored as ir ecall in save games. It’s purely for debugging. It means I can load a game in debug build, and see a list of every effect that has been applied to a variable, and what ‘tag’ it was given, to see where it comes from.
It looks like i forgot to change those tags, which si why they are wrong :frowning:
But its basically a user-editable debug field.


#27

Thanks for the idea, but I tried that. It plays slower in windowed mode, like having the mouse cursor lag behind my movements. You gave me an idea about my video card, I usually play games in their aspect ratio (cause I hate stretching too), but I tried out some other modes just in case. Unfortunately, none of them worked with the game.

Well, I didn’t expect you’d have a solution right now, but I thought I’d inform you of the problem. I think this is why developers went to consoles, lol. It’s too bad, because I like PC games.

Also, I didn’t get to say that I really appreciate you making this kind of game. It’s like Princess Maker 2, and Cute Knight (Kishi Kawaii). I love life sim games and there’s never very many of them. So, thanks!


#28

Cute Knight is an awesome game, I really loved it :smiley:


#29

Same here, although we are moving a bit off subject. :wink:


#30

Hey Cliff

I just had Kudos crash a couple of days after I bought a pet… I wasn’t doing anything exceptional. It was a fairly severe crash though, it locked my system up totally. Is there anything I can do to narrow down what caused it to crash? I think I was just pressing the group activities button at that point.

Saraswati


#31

If you haven’t started the game since, please send the debug files (inside the games ‘debugdata’ folder to me by email. It might be vaguely related to a bug I just fixed…


#32

Patch 1.05
I reckon I’ve fixed the restaurant crash and glitches. hurrah!

New patch:

positech.co.uk/kudos2/patche … to1.05.exe

changes:


#33

Hi Cliff

What is the path for the debug folder? I’m poking around in the Kudos 2 folder and I can’t find it.

Saraswati


#34

Hi Cliff,
Just patched to 1.05
Had a crash to desktop, first i’ve had with kudos2. It seemed to happen when i was sleeping on the sofa but it wasn’t the first time i have slept on the sofa… i’ll send you the debugdata :slight_smile:

Sometimes, when it snows or rains and different boxes are open, lines appear in the right hand box, also the o in Relaxation seems to distort.

The certificate background doesn’t showup (since applying patch 1.04) but the text and OK button are fine.


#35

I am having crashes after installing 1.05.
It crashes locking up my whole PC and have to turn off power to restart it.
My instances happened after getting some invites. I went to cancel them and it crashed.
I am just going to go back to V1.04- I only had one CTD with that version.


#36

im having trouble installing patches. I run it and then i get a popup that says patching has failed. :frowning:


#37

faymelevy: Check what version your kudos says it is. It’s on the righthand side of the opening screen. Currant is Final 1.05. If yours is 1.03, and you try to install patch 1.05 it will just fail, and not tell you why (not very helpful, that).

You need to install each patch to get to the next.

Cliff, if I can make a suggestion, it would be great if you could edit the first post on this thread to include all of the patches. I had some trouble figuring out why I couldn’t patch 1.03 to 1.05 myself, since I hadn’t seen 1.04 while looking through the thread the first time.


#38

Shaileya: I didn’t know that. Thanks so much. I went back and installed the other one and then this one and it all worked out. Thanks again. :slight_smile:


#39

Ok I keep having an error everytime I want to save and or load a previous or game I just saved… I get *could not find job\src\SIM_JobBase .cpp 507

What do I do?

I tried to install any of the patches from this thread and they all FAILED… Any help would be greatly appreciated! Thank you


#40

Are you trying to load a game created with an earlier version of the game, because in some cases, that may not work.