Mac - Game loads to white screen

I’m on OS X Yosemite 10.10.3

Game ran fine before - was playing this morning.

Then I tried switching to a windowed version. The icons wouldn’t load correctly - they all showed white boxes instead of icons.

So I switched back to full screen mode.

Now, when I launch the game, it launches as a big white screen (full screen). The only button that seems to do anything is the [Esc] key, and all that does is close the application.

I uninstalled and reinstalled, but it’s doing the same thing.

Are there additional preference files stored on the Mac that I need to delete/edit in order to get the game to run again?

I got same problem.

I find a solution. If you bought game on steam go to library\Application Support\Democracy3\ and delete(but backup it first) prefs.ini. It worked for me.

Thanks Burro! I’ll give that a try tonight and see how it goes

Hmmmm… I did buy it on Steam, but don’t seem to have a Democracy 3 folder in my Application Support folder

Found it!

For folks having this problem on Mac, the solution posted above works. Here are the full steps:

  1. Open Finder
  2. Click on the ‘Go’ menu at the top of your desktop
  3. Hold down ‘Alt’ - this will show ‘Library’ in the Go menu
  4. Click ‘Library’
  5. In the Finder window, go down to Application Support > Democracy 3
  6. Copy ‘prefs.ini’
  7. Select the Democracy 3 folder, and click paste (this pastes the file as a backup)
  8. Move ‘prefs.ini’ to the trashcan
  9. Launch Democracy 3 again

The trouble seems to be that if you change the display setting, prefs.ini gets corrupted somehow and can’t load the setting that you changed it to, giving you a white screen.