Mac,Steam, CD key invalid


#1

Hi,

I purchased GSB for Mac through Steam. Have now bought the GC expansion and am trying to activate my online registration.

I did not receive a registration code in the email from Steam detailing my purchase. But when logged into Steam, Steam tells me that the CD key for the game is a number in the format xxxx-xxxx-xxxxx-x.

I have tried entering this code as the ‘registration code’ for GSP, and receive the ‘code invalid’ message. I’ve turned off my firewall and disabled the other protection I use (LittleSnitch). Nothing works.

I have noticed that when others have reported a similar problem on this board, the format of the number they provide is xxxx-xxxx-xxxx-x. So my CD key seems to have an extra digit in the third set of numbers. I have also noticed that when I try to ‘submit’ this number to GSB, the last digit of the number I have entered gets dropped, and the number is reformatted to xxxx-xxxx-xxxx-x. And I am told that the code is invalid.

Any suggestions are welcome! Thanks.


#2

The last number being dropped from the code when pasted seems to happen to a lot of people. You can simply add it back in. I had to do this with mine otherwise the code was (obviously) invalid. I’m not sure from your description, but did you try entering the code exactly as it was given to you (i.e. undoing the incorrect reformatting the program performs and adding the character back on the end)?


#3

Thanks for this suggestion. Yes, I have tried adding the last digit back on. And I never copied and pasted the number-- always typed it in by hand, and have checked and re-checked that I’ve been entering the number Steam gives me correctly.


#4

Solved it. I figured out that GSB requires ctrl-V for Paste, and typed the final digit manually after it was dropped. Online now. Thanks.